IBM Support

Unable to install AddOn using FileNet Content Engine Enterprise Manager Addon Installer

Troubleshooting


Problem

During the creation of the initial object store, the Object Store wizard was unable to install the 5.1.0 Base Content Engine Extensions AddOn causing several other addons to fail as well. Cancelling the AddOn install allowed Object Store to be created but the AddOn could not be installed via FEM's AddOn Installer as well.

Symptom

The following errors are logged in the P8_server_error.log:

YYYY-04-02T22:42:25.932Z 6E75EB9A ENG FNRCD0009E - ERROR method name: throwEngineException principal name: sd_FileNet_Admin Global
Transaction: true User Transaction: false Exception Info: The database access failed with the following error: ErrorCode 0, Message
'Transaction TransactionImple < ac, BasicAction:
-53e1febb:c122:515b5b94:85 status: ActionStatus.ABORTING > cannot proceed STATUS_ROLLING_BACK; - nested throwable:
(javax.transaction.RollbackException: Transaction TransactionImple < ac, BasicAction: -53e1febb:c122:515b5b94:85 status:
ActionStatus.ABORTING > cannot proceed STATUS_ROLLING_BACK)'
\ncom.filenet.api.exception.EngineRuntimeException: FNRCD0009E: DB_ERROR: The database access failed with the following error: ErrorCode 0, Message 'Transaction TransactionImple < ac, BasicAction: -53e1febb:c122:515b5b94:85 status: ActionStatus.ABORTING > cannot proceed STATUS_ROLLING_BACK; - nested throwable:
(javax.transaction.RollbackException: Transaction TransactionImple < ac, BasicAction: -53e1febb:c122:515b5b94:85 status:
ActionStatus.ABORTING > cannot proceed STATUS_ROLLING_BACK)'
failedBatchItem=0 errorStack={

Caused by: org.jboss.util.NestedSQLException: Transaction
TransactionImple < ac, BasicAction: -53e1febb:c122:515b5b94:85 status: ActionStatus.ABORTING > cannot proceed STATUS_ROLLING_BACK; - nested throwable: (javax.transaction.RollbackException: Transaction
TransactionImple < ac, BasicAction: -53e1febb:c122:515b5b94:85 status: ActionStatus.ABORTING > cannot proceed STATUS_ROLLING_BACK)
failedBatchItem=0

Caused by: javax.transaction.RollbackException: Transaction
TransactionImple < ac, BasicAction: -53e1febb:c122:515b5b94:85 status: ActionStatus.ABORTING > cannot proceed STATUS_ROLLING_BACK
failedBatchItem=0

Cause

Transaction Timed Out.

Resolving The Problem

  1. Increased the J2EE application server transaction timeout to 600 seconds or higher if necessary. The initial value is set to 180 seconds.
  2. Install the "5.1.0 Base Content Engine Extensions" AddOn again to the object store from FEM - right-click on the object store - select All Tasks - Install AddOn.

[{"Product":{"code":"SSNW2F","label":"FileNet P8 Platform"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Content Engine","Platform":[{"code":"PF033","label":"Windows"}],"Version":"5.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21633401