IBM Support

MustGather: Build issues when using Engineering Workflow Management

Troubleshooting


Problem

This document assists you in collecting the data necessary to diagnose and resolve IBM Engineering Workflow Management (EWM) build issues.

Cause


This MustGather assists you in collecting the data necessary to help you diagnose and resolve the issue. If you are unable to determine the root cause by using the information collected, you need to open a Support Case with IBM Support for further investigation, providing the data collected.

Resolving The Problem

You can use the IBM Support Assistant Lite (ISA Lite) Data Collector tool to quickly collect diagnostic files, such as log files, configuration files or to run traces. ISA Lite collects information about your Jazz Team Server environment and stores the information in a .zip archive file. If you have a need to open a service request with IBM Support for further assistance, you can send the archive file with the data collection so that we can help diagnose and fix problems.


The information in this document needs to be gathered in addition to the normal information and log collection done by ISA Lite.


 
General information
 

Common

  • Verify the JDK used by the build engine (it is recommended to use JDK provided with the EWM client if possible) might be specified by using one of the following methods:
    1. A vm argument in the jbe.ini:
      Example: -vm "\Program Files\IBM\TeamConcert\jdk\bin\java";
    2. On the command line used to start JBE:
      Example:  jbe -vm "\Program Files\IBM\TeamConcert\jdk\bin\java" .....
    3. Default JDK - open a command prompt in <jbe run dir> and check the result of: 'java -version'
       
  • If all the build fails on the same machine, check the disk space.
  • If the build failed randomly, check to see whether there is a time pattern (maybe the database is doing a backup).
  • Provide the build script.
  • Provide the Eclipse workspace log (Eclipse workspace/metadata named .log).
 
Verbose logs
 

Provide verbose logs:

  1. Use JBE -verbose option on the JBE engine

    jbe -repository https://localhost:9443/ccm -engineId xxx -userId xxx -pass xxx –verbose
     
  2. In the log4j2.xml (..server/<app>/conf) add the following lines:
    <Logger name="sqlTxLogger" level="DEBUG"/>
    <Logger name="com.ibm.team.repository.service.internal.RdbRepositoryDataMediator" level="DEBUG"/>
    <Logger name="com.ibm.team.core.repository" level="DEBUG"/>
    <Logger name="ws.exception.logged" level="DEBUG"/>
  3. Save the log4j2.xml file.
  4. Reproduce the issue and provide the ccm.log file as well as Eclipse workspace log. For the build request that is failing, get the build logs from the "Build overview", "logs" tab in the IBM Engineering Workflow Management Eclipse client.
     
 
JBE Data
 

Collect JBE data

 
  • Collect all log files under the JBE/Eclipse directory (under workspace and configuration)
     

  • Obtain build information: Go to Builds tab from the UI and collect the logs, stack trace, and errors for the build definition that is failing
     

  • Verify Build Queues and Build Engines statuses (capture UI screenshot)
 
More Resources
 

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Document Information

Modified date:
08 May 2023

UID

swg21632450