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Error CFG1073E Can not discover profiles

Troubleshooting


Problem

On distributed systems if the profileRegistry.xml file was moved from the standard location (AppServer_home\properties), the ITCAM Data Collector for WebSphere configuration utility (config.bat) fails to discover the AppServer_home\profiles directory. The following error message is displayed: CFG5026E Critical error in config.py CFG1073E Can not discover profiles. Make sure there is a local application server profile created

Cause

The config.bat configuration utility reads the AppServer_home\properties\profileRegistry.xml file to get a list of defined application server profiles for the WebSphere installation. If the profilesRegistry.xml file was moved to another location, then the config.bat configuration utility can't find the profiles directory.

Resolving The Problem

Resolve this problem by copying the profileRegistry.xml file into the AppServer_home\properties folder. On Unix and Linux systems make sure that the file has read permission set..

[{"Product":{"code":"SS3PHK","label":"Tivoli Composite Application Manager for SOA"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"ITCAM for SOA (Dist)","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"},{"code":"PF027","label":"Solaris"},{"code":"PF010","label":"HP-UX"}],"Version":"7.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21620796