Troubleshooting
Problem
When you use features of the product that use an embedded web browser, such as Rich Page Editor or Web Browser preview, web pages with Dojo content might cause a process failure when Internet Explorer version 8 is installed.
Symptom
A process failure is known to occur when you add the "dojox.mobile.IconContainer" Dojo widget to a Dojo Mobile web page. The web page might briefly render, but then the user interface freezes and eventually the product window disappears. There might be other combinations of specific Dojo widget types and Dojo versions that expose a similar failure scenario using Internet Explorer 8.
Cause
The process failure occurs in the native Internet Explorer 8 browser code. This issue is being tracked in the following Eclipse bugzilla defect:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=391726
Environment
Windows platforms using Internet Explorer 8.
Diagnosing The Problem
If the product fails while you are viewing a page with the "IconContainer" Dojo mobile widget, it is likely caused by this problem. The javacore logs will indicate that the failure occurred in the "ntdll.dll" module.
Resolving The Problem
Because this problem occurs in the native Internet Explorer 8 code, these are the available workarounds:
- Use a different (preferably higher) version of Internet Explorer, if available.
- Avoid using Internet Explorer as the embedded browser. Alternate browser options are available in Rich Page Editor on Windows platforms if the 32-bit version of the product is installed. These alternate browser options do not exhibit the process failure issue.
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Document Information
Modified date:
16 June 2018
UID
swg21615914