IBM Support

Checking for Disk bottlenecks using NMON on Version 6.x, 7.x servers

Troubleshooting


Problem

NMON output can be used to check for Disk performance bottlenecks

Cause

Poor Disk performance

Diagnosing The Problem

NMON output can be used to help determine a disk bottleneck. Look at the weighted average (maroon color) for disks that are consistently above 50%.

Resolving The Problem

Below are some examples of NMON output.


NMON (Diskbusy Tab) Example #1 (Some disks having high I/O), perhaps spiking, or an application using hdisk 50 and 16 are heavily using. Overall these disks are normal use.


NMON (Diskbusy Tab) Example #2 (Heavily Loaded System). Disk may be the bottleneck.

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"6.3;7.1","Edition":"Edition Independent","Line of Business":{"code":"LOB26","label":"Storage"}}]

Product Synonym

tsm adsm itsm IBM Spectrum Protect

Document Information

Modified date:
17 June 2018

UID

swg21615173