Troubleshooting
Problem
ACN5909E hr=0x81002746 MAPI_E_LOGON_FAILED when attempting to restore a Mailbox
Symptom
Data Protection for Exchange GUI Mailbox Restore fails with the error:
"ACN5909E. The MAPI subsystem logon has failed. Please check that you have an active mailbox and sufficient privileges for this operation."
Cause
The Mailbox for the user performing the restore is not found.
Diagnosing The Problem
A trace of the mailbox restore shows a failure to find the mailbox for the Admin user performing the restore:
09/26/2012 09:33:38.069 [008928] [17796] : exceri.cpp (4317): USER: admin-exch1
09/26/2012 09:33:38.069 [008928] [17796] : adutil.cpp (3429): GetMailboxForUser(): Enter
...
09/26/2012 09:34:54.904 [008928] [17796] : adutil.cpp (3538): mailbox alias NOT FOUND for user admin-exch1
...
09/26/2012 09:37:33.286 [004616] [7692] : MAPIProfile.cpp ( 252): ConfigureMsgService() alias: =admin-exch1
09/26/2012 09:37:33.738 [004616] [7692] : MAPIProfile.cpp ( 263): ConfigureMsgService() error: 0x81002746
...
09/26/2012 09:37:33.754 [004616] [7692] : mapihandler.cpp (2053): logon to MAPI
09/26/2012 09:37:33.754 [004616] [7692] : mapihandler.cpp (2113): MAPILogonEx error: MAPI_E_LOGON_FAILED
Resolving The Problem
- When performing a mailbox restore using Data Protection for Exchange, this restore can fail with an hResult=0x81002746. The 0x81002746 error is defined as: MAIL_E_NAMENOTFOUND
- Ensure that this Admin user has a mailbox and that the mailbox is functional
- Verify that the mailbox is not hidden and can be seen in the Global Address List.
- If restrictive permissions are set for this Admin user, grant more authority so the mailbox is accessible.
This error occurs during the MAPI internal processing. The software looks in the Global Address List (GAL) to find information for the user who logged on and is performing the restore. The user is usually the Exchange Admin. When the information is not found, the error is reported. The error indicates that the mailbox for the logged on Admin user cannot be found. To correct this problem, check the following areas:
As indicated in the Data Protection for Exchange and FlashCopy for Exchange product documentation, the user that performs a mailbox restore must have an active mailbox within the domain.
Product Synonym
TSM
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Document Information
Modified date:
17 June 2018
UID
swg21613470