Troubleshooting
Problem
Version 6 Tivoli Storage Manager BACKUP DB fails with error ANR2968E Database backup terminated. DB2 sqlcode: -2033. DB2 sqlerrmc: 426.
Symptom
The following error is encountered after initiating a BACKUP DB process when API trace is enable:
tsm:TSM>backup db type=full devc=<devclassname> wait=yes
ANR0984I Process 3 for DATABASE BACKUP started in the FOREGROUND at 08:54:15 PM.
ANR2280I Full database backup started as process 3.
ANR2968E Database backup terminated. DB2 sqlcode: -2033. DB2 sqlerrmc: 426.
ANR0985I Process 3 for DATABASE BACKUP running in the FOREGROUND completed with completion state FAILURE at 08:54:16 PM.
ANS8001I Return code 4
Cause
The sqlerrmc 426 retrun code means the following:
0426 DSM_RC_CANNOT_OPEN_TRACEFILE
If the user does not have write permission for the file pointed by the TRACEFILE option, dsmSetup or dsmInitEx/dsmInit will fail with the return code DSM_RC_CANNOT_OPEN_TRACEFILE (426).
Resolving The Problem
You can either remove the trace options or change the location where the tracefile points. Determine if tracing is required and if it is not needed, then the trace parameters should be removed from the options file. If it is necessary to obtain a trace for troubleshooting of another issue, then make sure the instance user has write permissions for the file specified by the TRACEFILE option. It is necessary to specify a location where the Tivoli Storage manager instance user has write permissions.
Product Synonym
TSM
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Document Information
Modified date:
17 June 2018
UID
swg21591648