IBM Support

Connection authorization failure occurred

Troubleshooting


Problem

Updating a component from an existing subscription fails with an 'invalid userid/pw error even though testing a DB2 connection while creating a new SUBSCRIPTION/Nomination against the same data source works

Symptom


BVS-DBA-0900 Unable to install the database.
ERROR DatabaseInstallationManager T23
com.ibm.db2.jcc.b.mm: [jcc][t4][2013][11249][3.50.152] Connection
authorization failure occurred. Reason: User ID or Password invalid.
ERRORCODE=-4214, SQLSTATE=28000

Cause

Encryption problem with the BV repository username and password

Resolving The Problem



Launch Cognos Configuration for the main BV server -> Go to the section where we define the DB repository -> Change the user Id and password - save it to force regeneration of the encryption keys - then try to test the connection in Cognos Configuration. If that all works - then launch a browser to
connect to DB and log in.

If that doesn't work - make sure that user hasn't been locked out of the DB for too many connection attempts or such.

[{"Product":{"code":"SSWRXS","label":"Cognos 8 Business Viewpoint"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Business Viewpoint","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21589945