Question & Answer
Question
When client connections try to reach the Informix instance, the error -951 (User username is not known on the database server/User is not known on remote host) is raised, avoiding clients to connect.
Cause
You see errors like this in the online.log file:
13:14:57 Get Shadow Password for user [username] failed!
13:14:57 Check for password aging/account lock-out.
13:14:57 listener-thread: err = -951: oserr = 0: errstr = username@::ffff:10.10.10.31[server.host.net]: Incorrect password or user username@::ffff:10.10.10.31[server.host.net] is not known on the database server.
Several symptoms can cause such behaviour:
- SQLHOSTS file mispelled entries;
- DBSERVERNAME or DBSERVERALIASES onconfig parameters have no related entries in the SQLHOSTS file;
- NIS or LDAP servers misconfiguration or maintenance;
- INFORMIXDIR filesystem and/or its subdirectories have wrong permissions or ownership;
- User is locked or expired;
- oninit binary is somehow damaged or have wrong permissions.
Answer
Here's a list of things to check when facing such a problem:
1) Double-check the SQLHOSTS file for missing or mispelled entries regarding the DBSERVERNAME and DBSERVERALIASES onconfig parameter values;
2) Validate with the OS staff changes in the LDAP or NIS servers;
If none of the above were causing the issue, check the INFORMIXDIR filesystem for proper permissions and/or ownership:
1) Collect an ls -ltrR output from the INFORMIXDIR filesystem and compare its contents with the $INFORMIXDIR/etc/IIFfiles file;
2) Check for onwership too;
If the contents of the ls -ltrR diverges from the $INFORMIXDIR/etc/IIFfiles file, consider doing one of following:
1) Fix manually the missing permissions or ownership of every file/subdirectory;
2) Copy the INFORMIXDIR filesystem from another validated non-productive host;
3) Restore this filesystem from backup;
4) Re-install the Informix Server binaries.
In any of the options above, make proper backups of critical files like the onconfig, sqlhosts and ixbar files.
Important: these are just a few probable causes for this problem, if this document didn't solve your issue, consider calling IBM Informix Technical Support for assistance.
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Document Information
Modified date:
16 June 2018
UID
swg21588239