IBM Support

A CNTR0020E error message is seen with the human task manager for WebSphere Process Server (WPS)

Troubleshooting


Problem

The human task manager for WebSphere Process Manager throws a null pointer exception when business calenders are used for escalations

Symptom

When you configure a human task with a business calendar for escalations, it fails with the following exception while initializing the task:

CNTR0020E: EJB threw an unexpected (non-declared) exception during invocation of method "validate" on bean "BeanId(BusinessCalendar#BusinessCalendarEJB.jar#BusinessCalendar, null)". Exception data: java.lang.NoClassDefFoundError: com.ibm.wbiserver.calendar.lifecycle.LifecycleHelper$LazyHolderJ2EE (initialization failure)
at java.lang.J9VMInternals.initialize(J9VMInternals.java:140)
at com.ibm.wbiserver.calendar.lifecycle.LifecycleHelper.repf(LifecycleHelper.java:79)
at com.ibm.wbiserver.calendar.lifecycle.LifecycleHelper.getCalendarSchema(LifecycleHelper.java:112)
at com.ibm.bpmpriv.calendar.entities.LifecycleEntityFactory.createBizCalendar(LifecycleEntityFactory.java:444)
at com.ibm.wbiserver.calendar.impl.BusinessCalendarServiceImpl.applyDelta(BusinessCalendarServiceImpl.java:60)
at com.ibm.wbiserver.calendar.impl.BusinessCalendarServiceImpl.validate(BusinessCalendarServiceImpl.java:115)
at com.ibm.wbiserver.calendar.BusinessCalendarBean.validate(BusinessCalendarBean.java:116)
at com.ibm.websphere.scheduler.EJSRemoteStatelessBusinessCalendar_4a397e94.validate(Unknown Source)
at com.ibm.websphere.scheduler._UserCalendar_Stub.validate(_UserCalendar_Stub.java:275)
at com.ibm.ws.scheduler.UserCalendarHolder.validate(UserCalendarHolder.java:141)
at com.ibm.ws.scheduler.AbstractTask.validate(AbstractTask.java:557)
at com.ibm.ws.scheduler.SchedulerImpl$1.run(SchedulerImpl.java:676)
at java.security.AccessController.doPrivileged(AccessController.java:251)
at com.ibm.ws.scheduler.SchedulerImpl.updateOrCreate(SchedulerImpl.java:605)
at com.ibm.ws.scheduler.SchedulerImpl.create(SchedulerImpl.java:566)
at com.ibm.task.framework.ServiceSessionBean.createScheduledItem(ServiceSessionBean.java:611)
at com.ibm.task.framework.EJSLocalStatelessTaskServiceManagerBean_fd52dd76.createScheduledItem(Unknown Source)
at com.ibm.task.core.scheduler.HTMSchedulerImpl.create(HTMSchedulerImpl.java:147)

Cause

When you start the process server, there is a connectivity issue with WebSphere Process Server common database. This issue occurs because of database connectivity issues or the database user ID is locked.

Resolving The Problem

To resolve this issue, complete the following steps:

  1. Resolve the connectivity and user ID issues with WebSphere Process Server common database
  2. Restart WebSphere Process Server.

[{"Product":{"code":"SSQH9M","label":"WebSphere Process Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Human Task Manager","Platform":[{"code":"PF002","label":"AIX"}],"Version":"7.0.0.4;7.0.0.3;7.0.0.2;7.0.0.1;7.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
15 June 2018

UID

swg21572481