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[Db2] フェイルオーバー・クラスター環境の待機系で Db2 のアンインストールに失敗した場合の対応方法

Question & Answer


Question

TSA や PowerHA  などを利用したフェイルオーバー・クラスター環境において、待機系で DB2 をアンインストールしようとすると以下のエラーで失敗します。原因と解決方法を教えてください。
DBI1016I プログラム db2_deinstall がアンインストールを実行中です。お待ちください。

現在の DB2 コピーに関連した DB2 インスタンスがある間は、アンインストール・プロセスを続行できません。
この DB2 レベルからレベルを上げるまたは下げる必要がある場合は、目的のレベルに対応した DB2 イメージから installFixPack コマンドを使用してください。このコピーが更新されます。

この DB2 コピーをアンインストールしようとしているだけの場合は、事前に関連インスタンスをドロップしておくか、
またはこの DB2 コピーと同じバージョンの別の DB2 コピーにインスタンスを更新した後に、db2_deinstall コマンドを再始動してください。

実行の中に大きなエラーが発生し、プログラムが早期に終了しました。問題が解決しない場合は、技術サービス担当者に連絡してください。 詳しくは、「/tmp/db2_deinstall.log.565270」にある DB2 アンインストール・ログを参照してください。

Cause

フェイルオーバー・クラスター環境では、Db2 プロファイル・レジストリーは主系と待機系のそれぞれに存在しており、共有されていません。
そのため、主系で db2idrop コマンドを実行してインスタンスを削除しても、待機系のプロファイル・レジストリーには反映されません。待機系のプロファイル・レジストリーのインスタンスのエントリーは db2greg コマンドで削除する必要があります。

Answer

主系でアンインストールを実施後、待機系では以下の db2greg コマンドを実行してインスタンス・エントリーを削除してから Db2 のアンインストールを実施してください。
db2greg -delinstrec instancename=<インスタンス名>,service=DB2

なお、Db2 V9.1, V9.5 環境では、プロファイル・レジストリーはインスタンス・プロファイル・レジストリー (<db2_installation_path>/profiles.reg) に格納されます。
Db2 V9.7以降は、profiles.reg およびグローバル・プロファイル・レジストリー (<db2_installation_path>/default.env) は Db2 インストール・パスから除去され、Db2 インスタンス情報とグローバル・レジストリー情報はグローバル・レジストリー・ファイル (global.reg) に格納されています。


運用上の考慮点
  • グローバル・レジストリーは db2greg ツールを使用して編集できますが、root インストールでのグローバル・レジストリーの編集には root 権限が必要です。
  • db2greg ツールは、IBM ソフトウェア・サポートからの要請があった場合に使用するコマンドですので、上記以外の目的では使用しないでください。

関連情報
db2greg を使用したグローバル・レジストリーの表示および変更 (UNIX)
Db2 V9.7 の新機能: レジストリー・ファイルが DB2 インストール・パスから除去された
 
お問合せ先
技術的な内容に関して、パスポート・アドバンテージの契約のもと Db2 テクニカル・サポートへお問い合わせください。
Db2 テクニカル・サポート

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Document Information

Modified date:
26 August 2023

UID

swg21572440