Troubleshooting
Problem
Unable to start the Tivoli Storage Manager Server due to TSMDB1 DB2 database not upgraded.
Cause
Tivoli Storage Manager TSMDB1 database not upgraded due to DB2 APAR IC69420
Diagnosing The Problem
When the Tivoli Storage Manager is started, the following errors are received which will terminate the startup of the Server :
ANR0152I Database manager successfully started.
ANR0172I rdbdb.c(1759): Error encountered performing action ActivateDatabase.
ANR0162W Supplemental database diagnostic information:
-5035:**No State Information Available (55)**:-5035 (**No Other Information Available (110)**).
The db2diag.log will report the following messages:
MESSAGE : ADM0501C A stack overflow exception has occurred. The DB2 instance has terminated abnormally. To remedy this problem, you may increase the default stack size for db2syscs.exe using the db2hdr utility as follows: db2hdr \sqllib\bin\db2syscs.exe /s:<stackreserve>[, <stackcommit>] Note that increasing the default stack size will consume virtual memory space and may reduce the maximum number of concurrent connections. Contact IBM Support for further assistance.
SQL5035N: The database must be upgraded to the current release.
Resolving The Problem
Open a DB2 command window by selecting
Start > All Programs > IBM DB2 > Command Line Tools > Command Window - Administrator
1: Verify that you are running the proper DB2 level that is required by the Tivoli Storage Manager version. The following command can be run to view this info:
db2level
You can verify the version that is packaged with your Tivoli Storage Manager version at the following link:
http://www.ibm.com/developerworks/wikis/display/tivolistoragemanager/TSM+Schedule+for+Fix-Packs
2: View the current setting for the AGENT_STACK_SZ.
db2 get dbm cfg
3: Increase the value for the AGENT_STACK_SZ from current value if it is less than 128 to 128.
db2 update dbm cfg using AGENT_STACK_SZ 128
4: Recycle the DB2 instance.
5: Upgrade the TSMDB1 database.
db2 upgrade db TSMDB1
6: Restart your Tivoli Storage Manager Server.
NOTE: You may reset the value of the AGENT_STACK_SZ to original value if needed afterwards.
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Document Information
Modified date:
17 June 2018
UID
swg21461755