Troubleshooting
Problem
The retry mechanism for failed events generated for asynchronous Service Component Architecture (SCA) calls involving business processes is modified in WebSphere Process Server V7.0.
Cause
The retry configuration determines the threshold value before a runtime exception at the target service is returned back to the caller business process service in an asynchronous invocation scenario, The retry threshold is configured in the module destination and resides in the SCA System Bus, on the Service Integration Bus (SIB). Refer the following graphic:

The Exception Destination in the module destination configuration is shown in the following graphic:

The Maximum Failed Deliveries is the threshold or the retry limit after which the runtime exception is returned back to the calling business process. Prior to WebSphere Process Server V7.0, the retry behavior for business process modules is described below:
When the Maximum Failed Deliveries is set to n the target service is invoked n-1 times and the exception is returned to business process to handle. For example, if the Maximum Failed Deliveries is set to 5, the target service will be invoked 4 times including the original invocation. On the fourth retry (fifth delivery) the SCA runtime will interpret the message and return the message to the business process with reason for failure.
With WebSphere Process Server V7.0 the retry behavior is modified as described in the following information:
When the Maximum Failed Deliveries is set to n the target service is invoked n times and the exception is returned to business process to handle. For example, if the Maximum Failed Deliveries is set to 5, the target service will be invoked 5 times including the original invocation, before the SCA runtime interprets the message. This modification ensures that the configured value for retry and the actual retry attempts are consistent.
Related Information
Product Synonym
WPS
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Document Information
Modified date:
15 June 2018
UID
swg21458614