Troubleshooting
Problem
Tivoli Storage Manager client restores create files prefixed with $TSM.
Symptom
File system contains files prefixed with $TSM
Cause
There are files that may not be replaced after the restore. When this occurs, the restore process prefixes the files with $TSM.
Resolving The Problem
During a client restore, when system files are locked by the operating system and cannot be overwritten, temporary files prefixed with $TSM are created. Once the $TSM files are created, the following registry key is updated:
HKLM\CurrentControlSet\Control\Session Manager\PendingFileRenameOperations
At the time of reboot, the $TSM files will replace the original files, that is the operating system will use the key contents to replace the original files with those that were restored. After the reboot, the $TSM files will be deleted.
A reboot is the best way to remove these temporary $TSM files. It is possible to delete these files, however, then the system would not be completely restored to the intended point since those changes were not applied to the system.
Because the restore will be creating $TSM files for every locked in-use file, the target volume may need several GB of extra free space to accommodate these temporary files.
IMPORTANT:
The restore process should only be performed once. If the restore needs to be attempted a second time, the system needs to be rebuilt again. For example, if a restore attempt fails, a resolution must be found, and the system needs to be rebuilt before attempting the next try. The system may run into issues if the restore is run multiple times without rebuilding the system. These issues might include (and not limited to) failure to boot or duplicate Control Panel entries.
Note: Since $TSM files are copies of the locked in-use files during a restore, having the files on the system could show the following symptom:
- Control panel may show duplicate icons.
Product Synonym
TSM
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Document Information
Modified date:
17 June 2018
UID
swg21450750