Troubleshooting
Problem
This technote explains how to resolve an error: "Error executing "C:\WINDOWS\system32\msiexec.exe" operation (status=1603)" which can occur when installing IBM Rational TestManager 7.0.2 or higher.
Symptom
The following error message was returned when installing IBM Rational TestManager 7.0.2:
Error executing "C:\WINDOWS\system32\msiexec.exe" operation
(status=1603).
See agent output log for more information: C:\Documents and Settings\All
Users\Application Data\IBM\Installation Manager\logs\native
\20100405_1115a.log
Also, the Windows Event Viewer shows an error similar to the following:
Product: CR11 -- Error 1904.Module C:\Program Files\Business
Objects\BusinessObjects Enterprise
11\win32_x86\plugins\auth\secLDAP\secldap.dll failed to register.
HRESULT -2147024770. Contact your support personnel.
Cause
As part of the TestManager installation, it tries to register dll's related to Crystal Reports, which is contained in the "BusinessObjects" directory mentioned above. However, TestManager v7.0.2 looks only for version 11 of Crystal Reports. If other products that use another version of Crystal Reports (such as IBM Rational ClearQuest) have previously been installed, the installation will fail.
Resolving The Problem
To resolve this issue, try one of the following workarounds:
- Uninstall any other products that may have used Crystal Reports (being sure to uninstall Crystal Reports itself as well. Then install TestManager, and reinstall the other products.
- Temporarily rename the "BusinessObjects Enterprise" folder to indicate version 11, and perform the TestManager install. Once it is complete, you can rename the directory back to the actual version.
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Document Information
Modified date:
16 June 2018
UID
swg21427085