Troubleshooting
Problem
Tivoli Storage Manager 6.X startup may fail with warning message ANR0162W and SQL code -1042 when performing action 'Activate Database'. The complete error messages are as below:
Symptom
ANR0152I database manager successfully started.
ANR0172I rdbdb.c( 1465): Error encountered performing action Activatedatabase. ANR0162W Supplemental database diagnostic information: -1042:** No state information Available
(135)**:- -1042< ** No Other Information Available (64)**)
Db2diag.log shows:
FUNCTION: DB2 UDB, data protection services, sqlpgint, probe:3600
RETCODE : ZRC=0x870F0025=-2029060059=SQLO_INVH "invalid file handle"
DIA8534C An invalid file handle was encountered.
After the above message, DB2 started marking all the pages as BAD PAGE.
MESSAGE : ADM14001C An unexpected and critical error has occurred: "DBMarkedBad". The instance may have been shutdown as a result
2010-03-29-13.28.45.115000-300 E237794F469 LEVEL: Severe
PID : 1976 TID : 3248 PROC : db2syscs.exe
INSTANCE: SERVER1 NODE : 000 DB : TSMDB1
APPHDL : 0-7 APPID: *LOCAL.SERVER1.100329182844
AUTHID : SYSTEM
EDUID : 3248 EDUNAME: db2agent (TSMDB1)
FUNCTION: DB2 UDB, base sys utilities, sqeLocalDatabase::MarkDBBad, probe:10
MESSAGE : ADM7518C "TSMDB1 " marked bad.
Cause
The issue is with DB2 database page corruption, which marked database page as a bad page. This causes an error when the Tivoli Storage Manager makes an attempt to perform the action 'Activatedatabase' during the start-up processing . The most likely reason of database page corruption or bad page is a Disk failure or inconsistency. This problem is often caused by hardware problems or possibly an Operating System issue.
Resolving The Problem
To resolve the problem , perform a point in time restore of the Tivoli Storage Manager server database to a time that is before the database corruption occurred.
or
Alternatively, use the db2dart utility from DB2 to determine the extent of the corruption for the database.
http://publib.boulder.ibm.com/infocenter/db2luw/v9r5/topic/com.ibm.db2.luw.admin.trb.doc/doc/c0020760.html
The report file should be provided to DB2 support for further investigation of the database corruption issue.
Related Information
Product Synonym
TSM
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Document Information
Modified date:
17 June 2018
UID
swg21426627