Troubleshooting
Problem
This technote identifies an error that can be encountered when opening IBM Rational RequisitePro projects that are configured to use an Oracle database on a Windows 64 bit machine.
Symptom
The full error message is:
Microsoft[SQL] ODBC Error : ORA-06413: Could not open connection.
Cause
This error is seen when RequisitePro does not have the proper Oracle Client installed.
Resolving The Problem
To resolve this error apply one of the following three solutions:
Solution 1
Ensure that you are using an Oracle 32-bit client and not an Oracle 64-bit client because RequisitePro is a 32 bit application and requires the 32-bit Oracle drivers to establish a connection to the database.
Solution 2
Install RequisitePro in a location where there are no spaces or parenthesis:
Example:
Installation path for RequisitePro 7.0.x.x:
C:\Rational\RequisitePro\
Installation path for RequisitePro 7.1.x.x
C:\IBM\RationalSDLC\RequisitePro\
Solution 3
If you are using a 32-bit Oracle client and still receive the error then please apply one of the following fixes. Use a version of the Oracle software that contains the fix for Bug 3807408.
NOTE: Currently the following patches have been released on Windows:
Windows 32-bit:
- 9.2.0.7.0 Patch 6: Apply Patch 4928723 or later
10.2.0.1.0 Patch 4: Apply Patch 4923768 or later
10.2.0.2.0 Patch 5: Apply Patch 5383042 or later
10.2.0.3.0 or later contains the fix
- 10.2.0.1.0 Patch 4: Apply Patch 4923787 or later
10.2.0.2.0 Patch 5: Apply Patch 5388871 or later
10.2.0.3.0 or later contains the fix
Product Synonym
ReqPro
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Document Information
Modified date:
16 June 2018
UID
swg21399601