Question & Answer
Question
How do I use the Microsoft Debug Diagnostic Tool (DebugDiag) to troubleshoot FileNet P8 and Image Services (IS) issues?
Cause
DebugDiag is designed to assist in troubleshooting issues such as hangs, slow performance, memory leaks or fragmentation, and crashes in any Win32 user-mode process running under Windows 2003 and Windows XP.
Answer
DebugDiag is composed of three views:
Rules: Creates a control script for the debugger host through a wizard. The script is located in \scripts.
Advanced Analysis: Runs a selected “Analysis Script” against one or more memory dumps.
Processes: Shows status of running processes/services
The Debug Diagnostic service must be started in order to capture output. DebugDiag setup depends on the issue under investigation, however below is a sample setup to capture a dump when a VWJs process aborts:
Start the DebugDiag tool from Start Programs => Debug Diagnostics Tool
On the Rules tab, select “Crash” to capture user crash dumps on unhandled exceptions, and click the Next button.
On the Select Target Type screen, choose “A specific process” and click the Next button.
From the Select Target process list, select the VWJs process name and click the Next button.
On the Advanced Configuration screen, under Unconfigured First Chance Exceptions, select “Full Userdump” from the dropdown box for the “Action type for unconfigured first chance exceptions” option.
On the same screen, click the Exceptions button under the Advanced Settings section. Click Add Exception. Select “C0000005” as the Exception Code, “Full Userdump” as the Action Type, and “0” for the Action Limit. Click “OK” and respond “Yes” to the messages.
Click “Save & Close” and respond “Yes” to the message.
On the Select Dump Location and Rule Name screen, accept the “Crash rule for all instances of VWJs.exe” for the rule name. The Userdump location can be changed on this screen as well.
Select “Activate the rule now” on the Rules Completed screen and click Finish.
Data to collect: All files in the Userdump directory. Include a description of any known circumstances leading up to the issue and document the time at which the issue occurred.. Also provide the Application and System Event Logs.
For more information: See the Microsoft website
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Document Information
Modified date:
23 March 2023
UID
swg21394571