IBM Support

Slow response when Rational Web client users login

Troubleshooting


Problem

This technote explains the cause and provides a resolution for the slow response of any IBM Rational Products when IBM Rational Web client users login.

Symptom

Attempts to login in the IBM Rational ClearQuest Web client results in 30 seconds to get response.

Cause

This combination might cause the performance problem:

    • Duplicate license server entries in the IBM Rational License Key Administrator
    • No user licenses are available

If there are duplicate/same license server entries, Rational License Key Administrator performs unexpected behavior to keep trying to get a license for around 30 seconds, even gets denied the request from the license server.


Example:

When there are duplicate Rational License server entries (fully qualified domain name -- FQDN, and host name without domain name qualifier) on the server list in the Rational License Key Administrator on a IBM ClearQuest Web server machine.

Also when the maximum number of user licenses is reached and a user try to login on IBM ClearQuest Web client, the user takes 30 seconds to login with restricted user mode.

Diagnosing The Problem

Check the IBM Rational License FlexLM server's log (lmgrd.log), which is located in <Install DIR>\Rational\lmgrd.log, for example, C:\Program Files\Rational\lmgrd.log

You might see the multiple [DENIED] output for a login user.


7:29:15 (rational) DENIED: "ClearQuest" user1#7.0.0@host01 (Licensed number of users already reached. (-4,342))
7:29:15 (rational) DENIED: "ClearQuest" user1#7.0.0@host01 (Licensed number of users already reached. (-4,342))
7:29:15 (rational) DENIED: "ClearQuest" user1#7.0.0@host01 (Licensed number of users already reached. (-4,342))
7:29:15 (rational) DENIED: "ClearQuest" user1#7.0.0@host01 (Licensed number of users already reached. (-4,342))

Resolving The Problem

Even fully qualified domain name (FQDN) , host name and IP address, which are pointing to the same physical machine, can be entered in the license server list, you should check only one of them for the same license server machine.

The only 1 same physical server machine should be in the license server list.

  1. Launch the IBM Rational License Key Administrator on the problem machine
  2. Click Menu > Setting > Server/Client Configuration > Check Licence Server List
  3. Check if multiple server entries point to the same physical server machine
  4. Check only one server entry among them or remove duplicate entries then keep only one.

    Recommendation:
    Use FQDN.

[{"Product":{"code":"SSTMW6","label":"Rational License Key Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"License Key Administrator","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21389816