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CICS INVOKE WEBSERVICE EIBRESP 16 EIBRESP2 17 Response message not received

Troubleshooting


Problem

Your CICS Transaction Server for z/OS (CICS TS) Web service requester application issues an EXEC CICS INVOKE WEBSERVICE (or INVOKE SERVICE) and does not receive a response message from the service provider, even though it has been sent.

Symptom

EXEC CICS INVOKE WEBSERVICE or INVOKE SERVICE results are EIBRESP 16 (INVREQ) EIBRESP2 17 (A remote Web service request did not return a response message).
The response shows HTTP/1.1 200 OK.. Connection : close..

Cause

The Content-Length header is missing. CICS requires the Content-Length header on all inbound HTTP/1.1 messages that have a message body.

Diagnosing The Problem

Trace CICS component SO 1-2, and review SO 0202 SOCK EXIT - FUNCTION (RECEIVE) trace entry. Review the socket data received from the service provider.

Resolving The Problem

Include the Content-Length header in the response data sent by the service provider.

[{"Product":{"code":"SSGMGV","label":"CICS Transaction Server"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Component":"Web Services","Platform":[{"code":"PF035","label":"z\/OS"}],"Version":"5.1;4.2;4.1;3.2","Edition":"","Line of Business":{"code":"LOB70","label":"Z TPS"}}]

Product Synonym

CICS/TS CICS TS CICS Transaction Server

Document Information

Modified date:
05 January 2026

UID

swg21386166