Troubleshooting
Problem
User launches Controller client. After a long time, user eventually receives logon box. User logs on. After a long time (several minutes), Controller finally appears.
Symptom
Example (Scenario #1)
In one real-life customer example, the logon process took 5 - 10 minutes to complete.
Example (Scenario #2)
In another real-life customer example, the logon process took several minutes (over 20 minutes for one particular user) to complete. The length of time varied between users - some took less time.
During the slow logging-on period, the Controller title bar said 'Not Responding' ('Keine Ruckmeldung' in German):
Cause
There are many potential causes of slow performance problems.
- TIP: For more examples, see other Technotes such as the ones linked below, especially 1367308.
This IBM Technote relates to the specific case where the client PC has an antivirus product that is aggressively scanning each client file download (or cache file), causing long time-outs.
Example #1
In one real-life customer example, the customer had Panda antivirus installed.
- This was agressively scanning all downloads from their Controller server (e.g. http://controllerserver/cognos8/controllerbin).
Example #2
In another real-life customer example, the customer was using F-Secure anti-virus.
- This was aggressively scanning both the cache location (%APPDATA%\Cognos\CCR) and also the client location (C:\Program Files\cognos\ccr\ccr.exe).
Environment
Scenario #1 - Client device launching Controller via the website
- In other words, user launching the client via a URL similar to: http://servername/ibmcognos/controllerbin/ccr.exe
- In one real-life example, the anti-virus product "Panda" triggered the problem (in this configuration).
Scenario #2 - Client device launching Controller via the local client
- In other words, user launching the client via a shortcut similar to: C:\Program Files (x86)\IBM\IBM Cognos Controller\CCR.EXE
- In one real-life example, the anti-virus product "F-Secure" triggered the problem (in this configuration).
Diagnosing The Problem
Scenario #2
During the 'slow' periods, in Task Manager notice how the total CPU consumed is just above the percentage relating to one CPU core. For example, in the picture below the total number of cores is 4 therefore the total CPU usage is just above (100/4) 25%:
By clicking on 'Processes' it will show what process is using 25% of CPU. This is likely to be your anti-virus product (during its scanning of cache files).
You may find that the 'hanging' is especially bad when launching JAVA-related functionality. Probably the easiest demonstration of this is if you click "Help - System Info":
As you can see, in one real-life example (see above) this caused massive CPU usage.
Resolving The Problem
Scenario #1
Either:
(a) Configure antivirus product (e.g. Panda) to not scan http:// downloads from the Controller server's website
or (b) install the Controller local client (CCRLocalClient.Msi) and launch Controller from the Start Menu shortcut
- In other words, run the program 'ccr.exe' from the client PC's hard drive (for example inside C:\Program Files\cognos\ccr\ccr.exe) not from a website URL.
Scenario #2
FIX: Reconfigure the client anti-virus program to exclude scanning from both of the following places:
(a) cache folder PLUS all of its subdirectories
- By default this %APPDATA%\Cognos\CCR
- For example: C:\Users\USERNAME\AppData\Roaming\Cognos\ccr
- Make sure that it is configured to *also* exclude all of its subdirectories!
and (b) client folder
- By default, for Controller 10.x this is: C:\Program Files (x86)\IBM\IBM Cognos Controller\
- For older versions of Controller, this is: C:\Program Files\cognos\ccr\
WORKAROUND: In one real-life customer case, the workaround was to simply (periodically) clear out (delete) the contents of the bad user's cache folder (%APPDATA%\Cognos\CCR).
- NOTE: This will reset the end user's 'favourites' and 'local preferences' inside Controller.
Related Information
Historical Number
1042029
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Document Information
Modified date:
15 June 2018
UID
swg21367435