IBM Support

'Standard Error ... 5 ... Subquery returned more than 1 value' when trying to add a new account or user - caused by invalid password for Windows user running Controller services

Troubleshooting


Problem

User tries to add a new user account inside Controller, but receives an error #1, User then tries to run the 'User Rights and Security Group Reports' report. User gets error #2.

Symptom

Error #1
Information
Standard Error
Number: 5
Source:
ControllerProxyClient:FrangoClient.clsRightsCache.InsertRecords.FrangoClient.cls Users.Insert:
FrangoClient.frmUserAndInstallationRights.SaveUser:FrangoClient.
frmUserAndInstallationRights.Ifile_DoSave
Description: System.WebServices.Protocols.SoapException: Server was unable to process request. --->
System.Runtime.InteropServices.COMException (0x80004005): Subquery returned more than 1 value. This is not permitted when the subquery follows =, !=, <, <=, >, >= or when the subquery is used as an expression.
at FrMiscST.MedlemSetTClass.InsertRecords(String sGuid, Recordset rdRecord, String sUser, Int32 LLocale)
at Cognos.Controller.Proxy.CCRWS.MedlemSetT_InsertRecords(String sGuid, DataSet rsRecord, String sUser, Int32 LLocale)
--- End of inner exception stack trace ---
OK

Error #2
IBM Cognos 8 Controller
Unhandled exception has occurred in a component in your application. If you click continue, the application will ignore this error
and attempt to continue.

Argument 'Number' is not a valid value.

Details Continue

Cause

There are several known causes for similar errors.
  • TIP: See separate IBM Technote #0960392 for more examples.
 
This Technote specifically relates to the scenario where the cause is that the customer had 2 separate Controller application servers, each using a different Windows domain user ID/password for its Controller services. The customer had mistakenly changed the password of one of these Windows domain users, without updating the password setting on the relevant Controller application server.

Diagnosing The Problem

To confirm this, look on the application server(s) for Event Log/viewer entries, inside the 'application log' referring to 'DCOM' errors.

Resolving The Problem

Ensure that the Windows domain 'service account(s)' used for the application server(s) are not accidentally modified/disabled over time, and that their password policy is configured so that they do *not* expire.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"Controller (Frango) 8.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Historical Number

1036592

Document Information

Modified date:
25 July 2019

UID

swg21347429