IBM Support

About Struts 2.x support with Rational Application Developer

Question & Answer


Question

Does IBM Rational Application Developer for WebSphere Software support Struts v2.x?

Cause

Need to develop Struts v2+ Web applications with Rational Application Developer v7.5 and future versions.

Answer

No version of Rational Application Developer provides specific tooling for Struts v2+ (such as it does for Struts v1.x configuration file editors).

While the product does not provide any tools specific to Struts v2+, users can use it (across all versions) to develop Struts 2+ based application. For example, you will need to obtain the Struts v2 runtime files from the Struts Web site yourself and manually add them to (and configure them within) a Dynamic Web project in which you intend to use Struts v2+.

Note: A Struts v2+ application is treated as a standard Dynamic Web project.

Related Information

[{"Product":{"code":"SSRTLW","label":"Rational Application Developer for WebSphere Software"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Web Development","Platform":[{"code":"PF033","label":"Windows"},{"code":"PF016","label":"Linux"}],"Version":"7.5;7.5.1;7.5.2;7.5.3;7.5.4;7.5.5;7.5.5.1;7.5.5.2;7.5.5.3;7.5.5.4;7.5.5.5;8.0;8.0.1;8.0.2;8.0.3;8.0.4;8.0.4.1;8.0.4.2;8.0.4.3;8.5;8.5.1;8.5.5;9.0","Edition":"","Line of Business":{"code":"LOB36","label":"IBM Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21327401