IBM Support

AIX OS levels supported by XL Compilers

Preventive Service Planning


Abstract

What versions of the XL compilers can you use on your AIX OS level and do you need to install a PTF for your compiler to work on your AIX OS level?

Content

In support compilers:

Compiler
AIX 5.3
AIX 6.1
AIX 7.1 AIX7.2
XL C Compilers
XL C for AIX, V13.1.3
X
GA
GA
GA
XL C for AIX, V13.1.2
X
GA
GA
X
XL C for AIX, V13.1
X
GA1
GA
XL C for AIX, V12.1
GA
GA
GA
XL C for AIX, V11.1
GA
GA
XL C/C++ Compilers
XL C/C++ for AIX, V16.1 X X GA GA
XL C/C++ for AIX, V13.1.3
X
GA
GA
GA
XL C/C++ for AIX, V13.1.2
X
GA
GA
X
XL C/C++ for AIX, V13.1
X
GA1
GA
XL C/C++ for AIX, V12.1
GA
GA
GA
XL C/C++ for AIX, V11.1
GA
GA
XL Fortran Compilers
XL Fortran for AIX, V16.1 X X GA GA
XL Fortran for AIX, V15.1.3
X
GA
GA
GA
XL Fortran for AIX, V15.1.2
X
GA
GA
X
XL Fortran for AIX, V15.1
X
GA1
GA
XL Fortran for AIX, V14.1
GA
GA
GA
XL Fortran for AIX, V13.1
GA
GA

Out of support compilers:

 
Compiler
AIX 5.1
AIX 5.2
AIX 5.3
AIX 6.1
AIX7.1
XL C/C++ Compilers
XL C for AIX, V10.1
X
X
GA
GA
XL C/C++ for AIX, V10.1
X
X
GA
GA
XL C Enterprise Edition for AIX, V9.0
X
GA
GA
XL C/C++ Enterprise Edition for AIX, V9.0
X
GA
GA
XL C Enterprise Edition V8.0 for AIX
GA
GA
GA
X
XL C/C++ Enterprise Edition V8.0 for AIX
GA
GA
GA
X
XL C Enterprise Edition V7.0 for AIX
GA
GA
GA
X
XL C/C++ Enterprise Edition V7.0 for AIX
GA
GA
GA
X
XL Fortran Compilers
XL Fortran for AIX, V12.1
X
X
GA
GA
XL Fortran Enterprise Edition for AIX, V11.1
X
GA
GA
XL Fortran Enterprise Edition V10.1 for AIX
GA
GA
GA
X
XL Fortran Enterprise Edition V9.1 for AIX
GA
GA
GA
X

Legend
GA
OS level supported by the General Availability (GA) release of the compiler
(see notes 1 and 2)
X
OS level not supported by the compiler
OS level supported once the (linked) APAR is applied
(see note 2)

Notes

  1. Consult the product documentation for specific OS level prerequisites for installing and using the selected compiler. For example, the compiler may not install or function on the GA OS level; updates to the OS may be required before installing or using the selected compiler.
  2. While the GA level, or the first PTF providing the necessary APAR fix, will work on the given OS, it is best to apply the latest PTF (see the "Related information" links below).

[{"Product":{"code":"SSGH2K","label":"XL C for AIX"},"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Component":"Compiler","Platform":[{"code":"PF002","label":"AIX"}],"Version":"10.1;11.1;12.1;13.1","Edition":"","Line of Business":{"code":"LOB17","label":"Mainframe TPS"}},{"Product":{"code":"SSGH3R","label":"XL C\/C++ for AIX"},"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Component":" ","Platform":[{"code":"PF002","label":"AIX"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB17","label":"Mainframe TPS"}},{"Product":{"code":"SSGH4D","label":"XL Fortran for AIX"},"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Component":" ","Platform":[{"code":"PF002","label":"AIX"}],"Version":"All Versions","Edition":"Not Applicable","Line of Business":{"code":"LOB17","label":"Mainframe TPS"}}]

Document Information

Modified date:
06 February 2019

UID

swg21326972