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ClearCase Project Explorer fails with error: Assertion failed when opening streams in ClearQuest-enabled UCM projects

Troubleshooting


Problem

This technote explains how to resolve a failure that can occur when using IBM® Rational® ClearCase® (CC) Project Explorer, which fails with an "Assertion Failed!" when opening streams in IBM Rational ClearQuest® -enabled UCM projects.

Symptom


After upgrading to ClearCase 7.0.1.2 or 7.0.0.3 , the ClearCase Project Explorer may fail with the following error when opening a stream in a ClearQuest-enabled UCM Project:

Assertion failed!

Program: ...Files\Rational\ClearCase\bin\clearprojexp.exe
File: ../squid_ca_get_info.cxx
Line: 53

Expression: i < length()

For information on how your program can cause an assertion failure, see the Visual C++ documentation on asserts

(Press Retry to debug the application - JIT must be enabled)


This error occurs only when using existing streams in CQ-enabled projects. A newly-created stream in the same project as the failing streams does not have this issue. A newly created project, whether CQ enabled or not, does not have this issue.

You could also see the following error for this issue where the message in this case does not indicate Assertion failed!:


Caption: Microsoft Visual C++ Runtime Library

Runtime Error!

Program: C:\Pr...

This application has requested the Runtime to terminate in an unusual way.

Please contact the application's support team for more information.

Cause

The issue is caused by what is known as "skew" between the ClearCase PVOB and the ClearQuest User Database. If any of the linked ClearQuest Records are missing the stream_object_id OR if the ClearQuest record ID and ClearCase Activity ID do not match, this will happen.


This issue has been identified as a product defect in ClearCase Project Explorer under APAR PK72895.

Resolving The Problem


Defect APAR PK72895 has been resolved in the following ClearCase updates:


ClearCase 7.1
ClearCase 7.0.1
Fix Pack 7.0.1.4
ClearCase 7.0.0
Fix Pack 7.0.0.5

WORKAROUND

Until the issue is resolved in the Project Explorer, the following steps can be taken to resolve the data issues causing the crash:



cleartool checkvob -ucm -fix -force -crm_only project:<Failing Project Name>@\PVOB


cleartool checkvob -ucm -fix -crm_dbname <CQDB> -project <UCM_Project_Record_Name>

[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"GUI: Project Explorer","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.0.0.3;7.0.0.4;7.0.1.2;7.0.1.3;7.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"IBM Integrations","Platform":[{"code":"PF033","label":"Windows"}],"Version":" 7.0.1.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"UCM: Project","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
29 September 2018

UID

swg21321509