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msiexec.exe remains active after the installation procedure

Troubleshooting


Problem

The process msiexec.exe remains active after the installation of IBM® Rational® Suite product. This technote provides information on how you can discover possible causes.

Symptom

After you finalize the installation procedure of an IBM® Rational® Suite software product, the process msiexec.exe might be still active. Even after reboot, the process might remain active. After installation, the Rational products function error-free, but the process should not be active after the installation procedure is finished.

Cause

The cause is unknown.

Diagnosing The Problem

msiexec.exe belongs to the Microsoft Windows® Installer (MSI) Component and installs new programs that use MSI package files.

To investigate the problem on your computer, you can use Microsoft® Sysinternals Autoruns or a similar tool. This tool helps you to discover which processes start at startup of the operating system. Maybe msiexec.exe is on the list of processes that start when the operating system starts. Alternatively, a process that starts msiexec.exe is on that list.

Resolving The Problem

You can download Autoruns from the Microsoft page AutoRuns for Windows v9.01 .

Another thing you can do is change the order of the installation in such a way that the one with msiexec.exe comes first. You can see if there exists a dependency.

[{"Product":{"code":"SSJPDP","label":"Rational Suite"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Installation","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2003.06.00;2003.06.10;2003.06.12;2003.06.13;2003.06.14;2003.06.15;2003.06.16;7.0;7.0.0.1;7.0.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21273292