IBM Support

ANS1929E An error occurred saving the registry key

Troubleshooting


Problem

Unable to backup the windows registry with the Tivoli Storage Manager client.

Cause

Microsoft OS issue

Diagnosing The Problem

Errors similar to this will be logged into the error log ( dsmerror.log ):

ANS5250E An unexpected error was encountered.
TSM function name : ProcessRegistryEntry
TSM function : Backup of the registry hive 'C:\adsm.sys\W2KReg\REGISTRY\MACHINE\SOFTWARE\Device\HarddiskVolume2\WINNTPRO\system32\config\software' failed.
TSM return code : 4323
TSM file : ntreg.cpp (3255)
ANS1228E Sending of object '\\p3167w2k\c$\adsm.sys\W2KReg\*' failed
ANS1929E An error occurred saving the registry key.

Resolving The Problem

The following steps can be used to isolate the problem to be with the Tivoli Storage Manager client or Windows Operating system.

  1. Try the ntbackup.exe to backup the systemstate.
    Please check the logs to verify that there were no errors during the backup. If this fails, please contact Microsoft Support to help resolve this.
  2. Reboot the windows machine and retry the Tivoli Storage Manager client backup to backup the registry.
  3. If the backup still fails then further tracing will be needed to isolate the problem. Tracing can be generated via the following entries in the dsm.opt file and redo the backup.

    tracefile ?:\trace.txt
    traceflags service

    Send the trace.txt file to support along with the dsmsched.log and dsmerror.log files for review.
    NOTE: ? can be replaced with a valid Drive letter.

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Client","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Supported Versions","Edition":"All Editions","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21268690