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Silent Install fails when IBM Installation Manager finds a newer version

Troubleshooting


Problem

This technote explains why installing IBM® Installation Manager in silent mode may result in a #java.lang.NullPointerException error and provides instructions to resolve the issue.

Symptom

Attempts to install IBM Installation Manager and other IBM Rational® Development Platform (SDP) desktop products in silent mode, results in the following error message:


#Running Installation Manager version 1.0.0.I20061116_2314
#Found Installation Manager version 1.0.4.I20070606_1027c
#[09/Jul/2007:16:41:27 -0400]
#java.lang.NullPointerException
# at com.ibm.cic.agent.core.Agent.prepare(Agent.java:1663)
# at com.ibm.cic.agent.internal.core.InstallRegistry$ContextInstallRegistry.convertFormat(InstallRegistry.java:563)

Cause

This message indicates that IBM Installation Manager has found a new version from the IBM update sites but could not perform the update.

Since IBM Installation Manager depends on the response file, it does not know how to handle any event that was not recorded in the response file.

Resolving The Problem

  1. Add <preference name='com.ibm.cic.agent.core.pref.offering.service.repositories.areUsed' value='false'/> to the response file.
  2. Re-run the install script or command

"com.ibm.cic.agent.core.pref.offering.service.repositories.areUsed=false" will stop IBM Installation Manager from looking for a new update package.

For more information about IBM Installation Manager scripting, visit the IBM Installation Manager Information Center.

[{"Product":{"code":"SSDV2W","label":"IBM Installation Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Install","Platform":[{"code":"PF033","label":"Windows"},{"code":"PF016","label":"Linux"}],"Version":"1.0;1.0.0.2;1.0.0.3;1.0.0.4;1.0.0.5;1.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
25 October 2021

UID

swg21265620