Troubleshooting
Problem
This technote explains that test cases cannot be promoted using Test Script Services (TSS) API, and that they must be promoted manually when using IBM® Rational® TestManager.
Cause
It is not possible to promote a test case through the Test Script Services (TSS) Application Program Interface (API) of IBM® Rational® TestManager.
TestManager only supports manual promotion of test cases. This issue has been identified as a request for enhancement and is logged under RATLC00445934.
Resolving The Problem
The decision was made by Product Management to exclude the resolution of this enhancement from future upgrades and releases due to the significant architectural changes required to implement the solution.
Manually Promote a Test Case
You have to manually promote the test cases in a suite.
- To promote all test case results, right-click the test case results and select Promote All Test Cases:

Figure 1 Context menu when right-clicking the test case results.
Note:
- To have a test case promoted, you also need to save the test case result. You can do that by clicking File > Save Test Case Results or Ctrl + S. Alternatively you can click File > Save All ...
Versions 2003.06.16, 7.0 and later show the following dialog box:

Figure 2 Save Test Case Results, Always Yes or Always No.
If you choose Always Yes, TestManager always saves test case result when you close the Test Log window.
Note: Choosing Always Yes or Always No will stop the dialog from appearing.
Was this topic helpful?
Document Information
Modified date:
16 June 2018
UID
swg21265465