Troubleshooting
Problem
The Tivoli Storage Manager Backup/Archive Client GUI (dsmj) can hang after receiving a java core dump.
Symptom
The Java core will show the following error :
1TISIGINFO OUTOFMEMORY received
1TIDATETIME Date: <timestamp>
1TIFILENAME Javacore filename:
Cause
Java heap is not high enough.
Resolving The Problem
The default maximum memory allocated to java heap is 64MB.
Use one of the following two options to increase the java heap size:
- Use option -Xmx with the dsmj command. For example :
dsmj -Xmx128m
This command will start a dsmj with 128MB java heap. - The -Xmx is not available with the early versions of dsmj. In this case, perform the following steps to modify the java heap size:
a) make a copy of the dsmj script
b) modify the following line:
java -DDSM_LANG=en_US
-DDSM_CONFIG=/usr/tivoli/tsm/client/ba/bin/dsm.opt
-DDSM_DIR=/usr/tivoli/tsm/client/ba/bin -DDSM_LOG=/home/hager/dat
-DDSM_ROOT=/usr/tivoli/tsm/client/ba/bin -DDSM_OPTIONS= -jar dsm.jar
--to--
java -Xmx128m -DDSM_LANG=en_US
-DDSM_CONFIG=/usr/tivoli/tsm/client/ba/bin/dsm.opt
-DDSM_DIR=/usr/tivoli/tsm/client/ba/bin -DDSM_LOG=/home/hager/dat
-DDSM_ROOT=/usr/tivoli/tsm/client/ba/bin -DDSM_OPTIONS= -jar dsm.jar
-Xmx128m will allocate 128MB memory, If this is not enough, increase the number in 64MB increments until the error is no longer logged. This assumes that there is sufficient free memory on the machine that this does not cause paging to occur.
[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Client","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"All Supported Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]
Was this topic helpful?
Document Information
Modified date:
17 June 2018
UID
swg21231839