IBM Support

HMC error "Perfprovider may be busy or unavailable" when trying to view VIOS performance monitoring data

Troubleshooting


Problem

The Hardware Management Console (HMC) fails when you try to display Virtual I/O Server (VIOS) performance monitoring data.

Symptom

HMC error:
Error Code   101   "{"timeStamp" : "1573152210" , "viosld" : "1" "Msg" : "Perfprovider may be busy or unavailable"}

Cause

Virtual I/O Server defect in version 3.1.0.0 through 3.1.0.21

Environment

Virtual I/O Server managed via Hardware Management Console

Diagnosing The Problem

1. Determine the Virtual I/O Server version. Login as padmin, and run:
$ ioslevel
2. If ioslevel is 3.1.0.0, 3.1.0.10 or 3.1.0.21, the Virtual I/O Server is exposed to a defect fixed with APAR

Resolving The Problem

Restart perfprovider.  To do so, login to the Virtual I/O Server, as padmin, and run:
$ oem_setup_env
# stopsrc -s perfprovider
# lssrc -s perfprovider      ->Verify it is inoperative before you start it back. If it fails to stop, kill the PID (kill PID#).
# startsrc -s perfprovider  ->Rerun lssrc to verify it is active
Then, try viewing performance data again.
To obtain the APAR and prevent further recurrences, update the Virtual I/O Server to version 3.1.0.30.

Document Location

Worldwide

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Document Information

Modified date:
20 October 2021

UID

ibm13462765