Troubleshooting
Problem
Performance Data is not retrieved for the following agents running on Windows operating systems: - Monitoring Agent for Windows OS - Monitoring Agent for Microsoft Exchange Server - Monitoring Agent for Microsoft SQL Server - Monitoring Agent for Active Directory
Cause
The following IBM Tivoli Monitoring agents running on Windows operating systems collect data from Windows Performance Monitor (Perfmon) interfaces:
- Monitoring Agent for Windows OS
- Monitoring Agent for Microsoft Exchange Server
- Monitoring Agent for Microsoft SQL Server
- Monitoring Agent for Active Directory
Under certain circumstances the agent cannot retrieve data from the Windows Performance Monitor resulting in no data being available for situations, workspace views, and historical logging.
When the Windows operating system detects a problem in one of its extensible performance monitoring DLLs, it marks the DLL as "disabled." Any DLL that is disabled can no longer provide performance data through the Windows Performance Monitor
interfaces (Perfmon, or Performance Monitor APIs). This prevents IBM Tivoli Monitoring agents from gathering data supplied by the disabled DLL. For more information, see the Microsoft Support Knowledge Base article 248993 at the following Web address:
http://support.microsoft.com/default.aspx?scid=kb;EN-US;248993
Resolving The Problem
Follow the Resolution instructions provided in article 248993 to re-enable any performance monitoring extension DLLs disabled by Windows. Then, restart the agents.
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Document Information
Modified date:
17 June 2018
UID
swg21221690