Troubleshooting
Problem
IST380I ERROR FOR ID = Linename - REQUEST: ACTLINK, SENSE: 081C0000 for an XCA major node. All ACTLINKs fail for the major node. This item applies to all XCA SNA configurations.
Cause
This failure is normally caused by a configuration mismatch between the VTAM XCA major node and the XCA device specifications. There are many areas that can cause the problem, but the same sense code 081C0000 is usually issued, making it difficult to diagnose. See the SOLUTION area below for a list of areas to check.
Resolving The Problem
Here are some of the solutions that have been found that resolved the 081C0000 sense code:
1. The adapter number (ADAPNO) defined on the PORT statement in the XCA major node must match the port specified in the OAT table, which is part of the OSA's configuration. In the VTAM XCA major node definition, check the ADAPNO value on the PORT statement. The ADAPNO must match what you have defined in the OAT for this device entry.
(Old) OSA-2 ethernet adapters have only port 0, OSA-2 ENTR (ethernet) cards have two ports 0 & 1.
(New) All OSA-Express cards have only port 0.
2. The channel unit address (CUA) on the PORT statement must match the OSA configuration.
3. The SNA code must be loaded in the OSA device. (This step applies only to OSA-2 because OSA-Express and above have the SNA microcode shipped on the card.)
Verification steps to determine if the SNA support is in the OSA. Use the OSA/SF TSO interface:
(a) Start IOACMD.
(b) Specify QUERY command
(c) Look at the query dataset it creates, search for Flash Image Level.
If this is not filled in or it says incomplete then the support for SNA is not there.
4. The SNA entry must be started. If you check the OAT entry for the SNA device in question, it should show started: For older OAT formats:
oat.x.13 = started /* entry descriptor */
If it shows not started, it means that the OSA needs to be reset. A reset is done by configuring off/on the OSA CHPID. The reset MUST be configured off from all LPARs that have been defined to it as a resource. This can create problems if you have an LPAR that is not active. The best way to make sure the OSA is reset is to configure it off from the HMC console with the scope of the entire processor. This only applies to OSA-2. OSA-Express cards do not need to be reset manually. The port is reset when the config_osa is performed.
Most customers now would recognize this newer format:

5. Ensure that the SNA entry shows that all data is valid:
oat.x.2 = All data is valid /* Valid data indicator */
6. If IST1386I message was issued in addition to the IST380I, the allocation of the UCB failed. Check reason code in IST1386I message.
7. Contact the hardware device CE to assist in checking out the hardware card, cables, etc.
8. The adapter set an error code (other than code 7000 or code 201E) in response to a channel command during XCA device initialization. A CCW trace is needed to see this code.
If a definition mismatch or hardware problem is not found, you will need to provide CCW and VIT traces.
The parameters for the CCW trace are:
TRACE=URSP,IOP,SSCHP,CCWP,CSCH,HSCH
IO=SSCH=*** where *** is the CUA
CCW=(SI,CCWN=20,DATA=512,IOSB)
USR=FE1
The parameters for the VIT are:
F NET,TRACE,TYPE=VTAM,MODE=EXT,OPT=(LCS,PIU,MSG,PSS,SSCP,CIO)
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Document Information
Modified date:
15 June 2018
UID
swg21160618