Troubleshooting
Problem
Net was hanging. Z NET,CANCEL got no response. An IPL was required to get the system back. The system logs contained no error messages produced by NET. JES commands could be entered, but there was no response from JES or any started task.
Cause
The SYSTRACE in the dump shows many SVC '89', CALLDISPs in several CICS regions' ASIDs. These CALLDISPs are what is in most of the SYSTRACE. The issuer address is an extended private address. Using OMEGAMON on the running system, the customer found that this issuer address was in code in the non-IBM product TMON. The problem was in the Monitor for CICS/ESA - part of the TMON for CICS/ESA product. Here is an excerpt of the problem description taken from the TMON PTF cover letter. (Note: The LFS region referred to is the TMON started task that collects performance data from CICS.)
Module TMON645 was coded on the assumption that the LFS region is running at the same or higher dispatch priority as the CICS regions that are sending it data and would retry retry-able LFS errors until they succeeded. This behavior was perceived as a loop when the CICS regions outran the LFS region. This PTF sets a retry limit count of 50 for the nobuffers logging error from LFS. The retry loop uses CALLDISP to give up control from the CICS. This logic will allow other dispatchable units of equal or higher priority to run. We recommend the LFS be configured in a performance group or service class that meets this requirement with respect to the CICS regions logging data. When this limit is exceeded the nobuffers error is returned as a hard logging error to result in the action specified in option 10.2 Global options for logging critical.
Resolving The Problem
A fix is available from the TMON vendor, ASG. The PTF number is THO1276, and the module being fixed is TMON645.
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Document Information
Modified date:
15 June 2018
UID
swg21158485