IBM Support

OSUF errors received unexpectedly and incorrectly

Troubleshooting


Problem

OPERATIONS are set to OSUF when the JCL is available in the EQQJBLIB dataset.

Cause

Operation set to OSUF (JCL NOT FOUND in JOBLIB, or JCL UNUSABLE -- No JOBCARD or wrong JOBNAME on JOBCARD) when JCL *is* in a dataset in the EQQJBLIB concatenation.

Resolving The Problem

Check the following:

1. Check whether the EQQJBLIB has taken a new EXTENT while the CONTROLLER was active. The TWSz documentation strongly recommends that all LIBRARIES be defined as PDS/E. If they must be PDS, they should be a single EXTENT. If any library in the EQQJBLIB takes a new extent while the Controller is active, nothing in that new extent will be visible to TWSZ until the controller is stopped and restarted, thus closing and reopening the EQQJBLIB.

2. Make certain the JOBLIB member for the job receiving was not saved with the ISPF option PACK ON. When viewing JCL through ISPF, ISPF services automatically handle PACKED members. However, the TWSz submit task reads the JOBLIB directly and thus cannot read PACKED members.

3. Check to be sure that SMS is not relocating your job libraries. You must exempt the libraries in your EQQJBLIB from SMS management to ensure they will not be moved while the CONTROLLER is running.

4. Make certain that no COMPRESS or REORG is run against any library in an EQQJBLIB concatenation while the TWSz CONTROLLER is active.

[{"Product":{"code":"SSRULV","label":"IBM Workload Scheduler for z\/OS"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":null,"Platform":[{"code":"PF035","label":"z\/OS"}],"Version":"All Versions;Version Independent","Edition":"","Line of Business":{"code":"LOB35","label":"Mainframe SW"}}]

Product Synonym

TWSz

Document Information

Modified date:
13 September 2019

UID

swg21144567