Troubleshooting
Problem
This technote identifies resolutions to the Microsoft Word communication error -9, document file growth and hung session issues which might occur when working with a corrupt document in IBM Rational RequisitePro.
Symptom
The following are symptoms of a corrupt RequisitePro document:
- Microsoft Word communication error -9
- Saving the document causes the size of the document file to grow unexpectedly
- Attempts to save the document in RequisitePro cause the Word and RequisitePro sessions to hang
- Runtime error: index: 14 is outside of collection bounds
Cause
These issues often appear when the document has become corrupt.
Resolving The Problem
Converting the document to Rich Text Format and then back to a Word document while working with a RequisitePro Word document has been know to resolve this issue.
- Change the Project Properties so that the project documents can be opened in Word outside of RequisitePro: File > Project Administration > Properties.
- On the Documents tab, uncheck the box Save documents in RequisitePro format
- Exit out of RequisitePro
- Navigate to the project directory and double click on the affected document to open it in Word File > Save As ... and change the file type to Rich Text Format (*.rtf) and save a copy of the document as *.rtf (for example, Use Case specification.RTF)
- Close out of Word
- Double click on the *.rtf file created to open it in Word
- Access File > Save As ... and change the file type to Word Document (*.doc) and save a copy of the document as *.doc (for example, Use Case Specification.DOC)
- Close out of Word
- Rename the original document to save it as a copy (for example, Use Case Specification.UCS to Use Case Specification.bak)
- Rename the *.doc document created to be the original document (for example, Use Case Specification.UCS)
- Change the Project Properties so that the project documents cannot be opened in Word outside of RequisitePro: File > Project Administration > Properties ...
- On the Documents tab, check the box Save documents in RequisitePro format
You now should be able to open and save the document successfully in RequisitePro.
Related Information
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Document Information
Modified date:
16 June 2018
UID
swg21131072