IBM Support

System requirements for IBM Data Studio Version 2.2.x (IDE package)

Product Documentation


Abstract

This document describes the system requirements for IBM® Data Studio Version 2.2.x (IDE package).

Content

Ensure that your computer meets the system requirements before you install IBM Data Studio Version 2.2.x (IDE package).


Hardware requirements

Component

Requirement
MemoryMinimum of 1.5 GB RAM
Disk spaceA minimum of 2 GB of disk space is required for product package installation. Additional disk space is required for the resources that you develop.

Fix packs require additional disk space for download and extraction. See the download document for each fix pack for detailed requirements.
Display1024 x 768 display minimum using 256
Colors (or higher for best results)
Other hardwareMicrosoftR mouse or compatible
pointing device


Software requirements

The product supports the following operating systems:

Linux
Operating systemHardwareComments
Red Hat Enterprise Linux Desktop 4.0 x86-32
Red Hat Enterprise Linux Desktop 5.0 x86-32
Red Hat Enterprise Linux Desktop 5.0 x86-64 Product runs in 32-bit mode.
Red Hat Enterprise Linux Desktop 6.0
  • Desktop Edition
  • Workstation Edition
x86-32Supported in version 2.2.1 or later.
Red Hat Enterprise Linux Desktop 6.0
  • Desktop Edition
  • Workstation Edition
x86-64 Supported in version 2.2.1 or later.
Product runs in 32-bit mode.
Red Hat Enterprise Linux Server 4.0
  • AS Edition
  • ES Edition
x86-32
Red Hat Enterprise Linux Server 4.0
  • AS Edition
  • ES Edition
x86-64 Product runs in 32-bit mode.
Red Hat Enterprise Linux Server 5.0
  • Advanced Platform Edition
  • Server Edition
x86-32
Red Hat Enterprise Linux Server 5.0
  • Advanced Platform Edition
  • Server Edition
x86-64 Product runs in 32-bit mode.
Red Hat Enterprise Linux Server 6.0 x86-64 Supported in version 2.2.1 or later.
Product runs in 32-bit mode.
SUSE Linux Enterprise Desktop 10x86-32
SUSE Linux Enterprise Desktop 10x86-64Supported in version 2.2.1 or later.
Product runs in 32-bit mode.
SUSE Linux Enterprise Desktop 11x86-32Supported in version 2.2.1.1.
SUSE Linux Enterprise Desktop 11x86-64Supported in version 2.2.1.1.
Product runs in 32-bit mode.
SUSE Linux Enterprise Server 9.0x86-32
SUSE Linux Enterprise Server 9.0x86-64Product runs in 32-bit mode.
SUSE Linux Enterprise Server 10 x86-32
SUSE Linux Enterprise Server 10 x86-64Product runs in 32-bit mode.
SUSE Linux Enterprise Server 11x86-64Supported in version 2.2.1.1.
Product runs in 32-bit mode.

Windows
Operating systemHardwareComments
Microsoft Windows XP Professional (SP2)x86-32 Supported in version 2.2.0.2 and earlier.
Microsoft Windows XP Professional (SP2)x86-64 Product runs in 32-bit mode.
Microsoft Windows XP Professional (SP3)x86-32 Supported in version 2.2.1 or later.
Microsoft Windows XP Professional USGCBx86-32
Microsoft Windows Vista
  • Business Edition
  • Enterprise Edition
  • Ultimate Edition
x86-32
Microsoft Windows Vista
  • Business Edition
  • Enterprise Edition
  • Ultimate Edition
x86-64 Product runs in 32-bit mode.
Microsoft Windows Vista USGCBx86-32
Microsoft Windows 7
  • Enterprise Edition
  • Professional Edition
  • Ultimate Edition
x86-32Supported in version 2.2.0.2 or later.

Requires Installation Manager 1.3.2 or later.
Microsoft Windows 7
  • Enterprise Edition
  • Professional Edition
  • Ultimate Edition
x86-64Product runs in 32-bit mode.

Supported in version 2.2.0.2 or later.

Requires Installation Manager 1.3.2 or later.
Microsoft Windows Server 2003
  • Standard Edition (SP1)
  • Enterprise Edition (SP1)
  • Datacenter Edition (SP1)
x86-32
Microsoft Windows Server 2003
  • Standard Edition (SP1)
  • Enterprise Edition (SP1)
  • Datacenter Edition (SP1)
x86-64 Product runs in 32-bit mode.
Microsoft Windows Server 2003 R2
  • Standard Edition
  • Enterprise Edition
  • Datacenter Edition
x86-32
Microsoft Windows Server 2003 R2
  • Standard Edition
  • Enterprise Edition
  • Datacenter Edition
x86-64Product runs in 32-bit mode.
Microsoft Windows Server 2008 (SP2)
  • Standard Edition
  • Enterprise Edition
  • Datacenter Edition
x86-32Supported in version 2.2.0.2 or later.
Microsoft Windows Server 2008 (SP2)
  • Standard Edition
  • Enterprise Edition
  • Datacenter Edition
x86-64Product runs in 32-bit mode.

Supported in version 2.2.0.2 or later.
Microsoft Windows Server 2008 R2 (SP2)
  • Standard Edition
  • Enterprise Edition
  • Datacenter Edition
x86-64Product runs in 32-bit mode.

Supported in version 2.2.0.2 or later.

This version of the product was developed for use with the following Eclipse and JDK versions. These Eclipse and JDK levels are included with the product, but if you are extending an existing Eclipse environment, they are prerequisites.

Data Studio versionEclipse levelJDK level
Version 2.2.1.1Eclipse 3.4.2.6IBM JDK 1.6 SR 7
Versions 2.2.0.2 and 2.2.1Eclipse 3.4.2.4IBM JDK 1.6 SR 7
Versions 2.2 and 2.2.0.1Eclipse 3.4.2IBM JDK 1.6 SR 5

Ensure that you have one of the following Web browsers to view the readme file and the installation guide:

  • For Windows: Microsoft Internet Explorer 6.0 with Service Pack 1 or later
  • Mozilla 1.6 or 1.7.
  • Firefox 2.0 or later.


Supported data sources

The product supports the following data sources:

DatabaseVersionComments
DB2 for Linux, UNIX, and Windows9.1
9.5
9.7*
9.8*Supported in version 2.2.1 or later.
Product runs in toleration mode.
DB2 for iSeriesV5R3Supported in version 2.2.0.1 and earlier.
V5R4
DB2 for z/OS8.1
9.1*
10.1*Supported in version 2.2.1 or later.
Product runs in toleration mode.
IBM Informix Dynamic Server10.0
11.1
11.5
11.7Supported in version 2.2.1.1.

Note: *The database catalog filter in IBM Data Studio Version 2.2.1.1 supports only DB2 for Linux, UNIX, and Windows Version 9.7 and later and DB2 for z/OS Version 9.1 and later.

DB2 administration tasks are supported for the same data sources that are supported in Optim Database Administrator. For a list of those data sources, see the Optim Database Administrator system requirements.



Driver support

IBM Data Studio, Version 2.2.x requires the following drivers:

  • JDBC application clients:
    IBM Data Server Driver for JDBC and SQLJ v4.7 or higher for JDBC 4.0 applications
    IBM Data Server Driver for JDBC and SQLJ v3.57 or higher (or corresponding DB2 Connect version level) for JDBC 3.0 applications
  • JAVA Runtime Environment
    JRE 1.5
    JRE 1.6 for version 2.2.1 or later


Hosted development environments

IBM Data Studio, Version 2.2.x supports the following hosted development environments:

SoftwareVersionComments
Citrix Presentation Server4.5Supported in version 2.2.1.1.
Citrix XenApp5Supported in version 2.2.1.1.

[{"Product":{"code":"SS62YD","label":"IBM Data Studio"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"2.2;2.2.0.1;2.2.0.2;2.2.1;2.2.1.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
17 June 2018

UID

swg27016060