Question & Answer
Question
Why alert details displayed on IBM Call Center for Commerce product UI is not in proper user readable format ?
Cause
You are unable to read alert details.
Answer
The alert description in the problem scenario is in XML format, which is not allowed because of some security reasons.
For example :
When a payment execution fails with ResponseCode="HARD_DECLINED" then the COLLECTION_FAILED event triggers YCD_ProcessCollectionFailure_1.0 service and raises YCD_PAYMENT_FAILURE alert.
Though the Error Description field is mapped to InternalReturnMessage attribute and value is populated as a XML and gets stored as DETAIL_DESCRIPTION in the YFS_INBOX table and since the alert content is in XML format, it's display is not user friendly.
A code fix is made to encode all the content before getting displayed in text fields on UI to avoid cross site scripting issues. The alert description in the problem scenario is in XML format, which is not allowed because of above mentioned security reasons. Messages should be in plain text format only and should not contain any HTML/XML special characters.
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Document Information
Modified date:
16 June 2018
UID
swg22013270