IBM Support

IBM Tivoli Storage Manager (TSM) Client Requirements for V6.3, which is past End-of-Support (EOS)

Troubleshooting


Problem

Hardware and Software Requirements for IBM Tivoli Storage Manager (TSM) 6.3 clients, which reached End-Of-Support (EOS) on April 30, 2017.

Symptom

IBM Tivoli Storage Manager (TSM) 6.3 Client Requirements (V6.3 went EOS on April 30, 2017)

Note: There are no support extensions for TSM Version 6.3 products. Clients are encouraged to upgrade to a current product release that has not yet reached end of support. See in TSM Family Products with Support Extension contracts available which releases are active supported or which which are the recommendations for replacement.



AIX Version 6.3
HP-UX Itanium (IA64) Version 6.3
Linux on POWER Version 6.3
Linux x86/x86_64 Version 6.3
Linux zSeries Version 6.3
Macintosh Version 6.3
Solaris SPARC Version 6.3
Windows Version 6.3

AIX Version 6.3

Hardware
Operating System
Communication Protocol
System:
RS/6000 or System i or System p, or compatible hardware as supported by AIX

For IBM PowerHA® SystemMirror: One additional network adapter for each workstation.

Disk Space:
1.5 GB disk space is required to install the client, and all language packs.

Memory:
No additional RAM is required.
One of the following:
  • AIX 6.1
  • AIX 7.1
(64-bit kernel)

Backup/Archive client supports the following filesystems:
  • JFS
  • JFS2
  • JFS2 NFSv4
  • GPFS 3.4.0.4
    or higher fix level
  • GPFS 3.5
  • VxFS 5.0
One of the following:
  • TCP/IP, which comes standard with AIX
  • Shared Memory Protocol (with AIX server only)

Note:
The Web backup-archive client requires TCP/IP
Additional Software You can also search the IBM support portal for the files at: http://www.ibm.com/support/entry/myportal/support

Java GUI and Web backup-archive client require:
  • Java JRE 6 or 7
  • The Web client requires the Java plugin that is included in JRE 6 or JRE 7.
    The client is supported when running in a Firefox browser with the required plugin.

NetApp Data ONTAP




HP-UX Itanium (IA64) Version 6.3

Hardware
Operating
System
Communication
Protocol
System:
An HP Integrity server (Itanium) workstation or equivalent

Disk Space:
700 MB disk space is required to install the client, and all language packs.

Memory:
No additional RAM is required.
  • 11i V3 for Itanium 2 64-bit
  • TCP/IP, which comes standard with HP-UX
  • Shared Memory (with HP-UX Itanium server only)

Note:
The Web backup-archive client requires TCP/IP
Additional Software:
Web backup-archive client and Java GUI require:
  • Java JRE 6 or 7 for the Java GUI. Search http://www.hp.com for appropriate terms to locate the download. For example, search for Java JRE.
  • The Web client requires the Java plugin that is included in JRE 6 or JRE 7.
    The client is supported when running in a Firefox browser with the required plugin.



Linux on Power Version 6.3

Hardware
Operating System
Communication Protocol
System:
IBM System p or IBM System i, with POWER processors, as supported by Linux distribution

Disk Space:
200 MB disk space is required to install the client, and all language packs.

Memory:
No additional RAM is required for product installation. RAM requirements for running the product vary widely and depend on your environment, configuration, and tasks that you perform. Additional RAM might be required to run the product.
  • SLES 11 (64 bit)
  • SLES 10 (64 bit)
    Note: SP1 and higher required for snapshot image backup ​​
  • RHEL 5 (64 bit)
  • RHEL 6 (64 bit)
  • TCP/IP, which comes standard with Linux
  • Shared Memory (with Linux on Power TSM server only)
Additional Software

Java GUI and Web backup-archive client require:
  • Java: JRE 6 or 7 for the Java GUI
  • The Web client requires the Java plugin that is included in JRE 6 or JRE 7.
    The client is supported when running in a Firefox browser with the required plugin.

For EXT2/EXT3/XFS ACL support, you need the acl package.

The image backup and restore functions for LVM2 volumes require libdevmapper.so Version 1.01 or higher. If the library is at a lower level than required or it is not available, image backups for LVM2 volumes fail.
The libdevmapper.so library is distributed with the device mapper packages. On RHEL, the package is called device-mapper-libs and on SLES it is called device-mapper.



Linux x86/x86_64 Version 6.3

Hardware
Operating System
Communication Protocol
System:
Systems based on the X86 64bit processor architecture such as Intel-64 or AMD64

No additional RAM is required for product installation. RAM requirements for running the product vary widely and depend on your environment, configuration, and tasks that you perform. Additional RAM might be required to run the product.
  • SLES 11
    (including SLES 11 level in Novell OES 11 details)
  • SLED 11
  • SLES 10

  • (including SLES 10 level in Novell OES 2 details)
  • SLED 10
  • Note: SP1 and higher required for snapshot image backup on
    SLES 10 and SLED 10
  • Red Hat Enterprise Linux 6 for Servers
  • Red Hat Enterprise Linux 6 Desktop
  • Red Hat Enterprise Linux 5 for Servers
  • Red Hat Enterprise Linux 5 Desktop

Note: For "best effort" support of other Linux distributions, see this technote: http://www.ibm.com/support/docview.wss?uid=swg21417165
  • TCP/IP, which comes standard with Linux
  • Shared Memory (only with Linux x86_64 TSM server)
Additional Software
  • For EXT2/EXT3/XFS ACL support, you need the acl package.
  • The image backup and restore functions for LVM2 volumes require libdevmapper.so Version 1.01 or higher. If the library is at a lower level than required or it is not available, image backups for LVM2 volumes fail.
    The libdevmapper.so library is distributed with the device mapper packages. On RHEL, the package is called device-mapper-libs and on SLES it is called device-mapper.
  • Java GUI and Web backup-archive client:
    • Java GUI requires JRE 7
    • The Web client requires the Java plugin that is included in JRE 7.
      The client is supported when running in a Firefox browser with the required plugin.
Other Notes





Linux zSeries Version 6.3

Hardware
Operating System
Communication Protocol
System:
Any z system supported by the Linux distributions listed in this table, in 64 bit mode

Disk Space:
200 MB disk space is required to install the client, and all language packs.

Memory:
No additional RAM is required for product installation. RAM requirements for running the product vary widely and depend on your environment, configuration, and tasks that you perform. Additional RAM might be required to run the product.
  • SLES 11
  • SLES 10
    Note: SP1 and higher required for snapshot image backup ​
  • RHEL 5
  • RHEL 6
  • TCP/IP, which comes standard with Linux
  • Shared Memory (with zSeries Linux TSM server only)
Additional Software:
  • The Web client requires the Java plugin that is included in JRE 6 or JRE 7.
    The client is supported when running in a Firefox browser with the required plugin.
  • For EXT2/EXT3/XFS ACL support, you need the acl package.
  • The image backup and restore functions for LVM2 volumes require libdevmapper.so Version 1.01 or higher. If the library is at a lower level than required or it is not available, image backups for LVM2 volumes fail.
    The libdevmapper.so library is distributed with the device mapper packages. On RHEL, the package is called device-mapper-libs and on SLES it is called device-mapper.




Macintosh Version 6.3

Note: IBM Tivoli Storage Manager (TSM) 6.3 will reach End-Of-Support (EOS) on April 30, 2017. There will be no support extensions for TSM Version 6.3 products. Clients are encouraged to upgrade to a current product release that has not yet reached end of support. See in TSM Family Products with Support Extension contracts available which releases are active supported or which which are the recommendations for replacement.

Hardware
Operating System
Communication Protocol
System:
Any 64-bit Intel-based Macintosh
Macintosh OS X:
10.6
10.7
10.8, with 6.3.1 or higher client
TCP/IP
Additional software:
For Java GUI and Web GUI: Java JRE 6



Solaris SPARC Version 6.3

Hardware
Operating System
Communication Protocol
System:
SPARC system (sun4u or sun4v or equivalent)

Memory:
No additional RAM is required for product installation. RAM requirements for running the product vary widely and depend on your environment, configuration, and tasks that you perform. Additional RAM might be required to run the product.
  • Solaris 11 all updates
  • Solaris 10 (64 bit) update 1 or higher
  • TCP/IP, which comes standard with Solaris
  • Shared Memory Communication (with TSM Solaris server only, Solaris 10 only)
Additional Software
Java GUI and Web backup-archive client require:
  • Java JRE 6 or 7


Windows Version 6.3

Hardware
Operating System
Communication Protocol, Other
System:
32-bit: An x32 or compatible processor, or multi-processor based computer

x64: An AMD64 or EM64T processor or multi-processor based computer


Disk Space:
1.5 GB disk space is required to install the client


Memory:
128 MB RAM is required to install the client

Backup/Archive client (including Web client) and API client require one of the following:
  • Windows 2003 Server, all editions, all SPs supported*
  • Windows 2003 Server R2, all editions, support for same features as in Windows 2003*
  • Windows Vista, all editions, all SPs supported**
  • Windows 2008 Server and Windows 2008 Server Core, all editions, all SPs supported
  • Windows Server 2008 R2, all editions, all SPs supported
  • Windows 2012 Server, all editions and SPs supported with 6.3.1 or higher client ***
  • Windows 7, all editions, all SPs supported.
  • Windows 8, all editions, all SPs supported with 6.3.1 or higher client (Windows 8.1 not supported)***
One for the following, which are included in the base Windows product packages:
  • TCP/IP (the only one used for Web client)
  • Named Pipes (used in conjunction with TSM server running on same Windows machine)
  • Shared Memory (used in conjunction with TSM server running on same Windows machine)
Notes:
  • For information on which TSM client functions are supported on which hardware, see Function table
  • The Web client requires the Java plugin that is included in JRE 6 or JRE 7. The client is supported when running in Microsoft Internet Explorer and Mozilla Firefox browsers with the required plugin.
  • Only 64-bit clients can be run on 64-bit machines.
  • Automated System Recovery (ASR) for non-EFI systems

*NOTES on Windows 2003 requirements:
  • If you plan to back up System State or use Open File Support with the VSS snapshot provider, you must install Service Pack 1 (SP1) or higher Service Pack level, and you must install Microsoft hotfix roll-up packages 934016 (for COM+) and 940349 (for VSS). The hotfix roll-up packages can be found at Microsoft's support pagehttp://support.microsoft.com.
  • If you plan to use an x64-bit machine, apply the Microsoft hotfix for knowledge base article 908675. The hotfix is included in Service Pack 2 for Microsoft Windows 2003. In case you cannot apply the entire Service Pack this particular hotfix can be provided by Microsoft upon request. See details at http://support.microsoft.com/kb/908675.

**NOTES on Windows Vista requirements:
  • SP1 or higher is required to back up or restore System State with the VSS snapshot provider.

***NOTES on Windows 8 and Windows 2012 requirements:
The support does not include support for:
  • VMware Full-VM backups (guest VM is supported)

Related Information

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Component":"Client","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF014","label":"iOS"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"6.3","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21994532