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MustGather: Investigating problems with displaying wrong data when using Jazz Reporting Service

Troubleshooting


Problem

What information to collect to diagnose and resolve IBM Jazz Reporting Service (JRS) issues with displaying wrong data.

Cause

There are many reasons why the data in the data source of your report might not match the expected results. This MustGather will assist you in collecting the data necessary to help you diagnose and resolve the issue. If you are unable to determine the root cause using the information collected, you should open a case for further investigation providing the data collected.

Resolving The Problem

The information below should be gathered:

  1. Gather basic information about the system:
    1. Check the product version according to the TechNote 1986153: How to check the version of Jazz Reporting Service.
       
    2. Make a screen snapshot of "Data source properties" on "Data source" page. The properties are available after clicking on appropriate data source from Data sources list link: https://your-server:port/rs/endpoint.
       
    3. Provide the topology of your deployment.
       
  2. Gather more information about the issue:
    1. Simplify the report to display only the data which are in issue by for example removing all unnecessary traceability links and attribute columns.
       
    2. Make a screen snapshot what you see on the report and describe what you expect to see and why.
       
    3. Provide the steps how to create given report and send export the report according to Exporting Report Builder reports to compressed files document according to Exporting Report Builder reports to compressed files document.
    4. Provide the process template of affected project areas according to How to author and use a Process Description for a Process Template in CLM 2012 document, section "Import, export, or delete a process template with a process description".
       
    5. Gather additional information useful during problem analysis to narrow down the issue:
      • Which project areas/artifact types/data sources/users DO have the issue.
      • Which project areas/artifact types/data sources/users DO NOT have the issue.
         
  3. Check if the data is available in the data source. Check the query ran to display the report according to the TechNote 1986147: How to check the query ran to fetch report data and run this query. Gather both: the query generated and query result.
  4. Check if reloading the model according to the TechNote 1986146: How to refresh meta-model for the Data Source resolved the issue.
     
  5. Test data source connection status by clicking "Test connection" button after selecting your data source on https://your-server:port/rs/endpoint page. Additionally the screen snapshot of "Data source properties" on "Data source" page.
  6. Attempt to display the missing data in the application using the same user as the user running the report. Check if you have an access to that data. Gather a screen snapshot of that data in the application.
     
  7. Check if Global Configuration is enabled for affected project areas. If it is enabled:
    • If you use data warehouse as a data source, make sure that you are aware of the fact that data warehouse data is not available for the reports where Global Configuration is enabled.
    • If you use Lifecycle Query Engine as a data source, check if you are looking at the same stream in the application and the report.
       
  8. Collect additional debug traces:
    Procedure:
    1. Modify the log4j.rootLogger property in your [Install Dir]/server/conf/jrs/log4j.properties to the following value:
      log4j.rootLogger=DEBUG, file
       
    2. Recreate the report and run it again
       
    3. Roll back the value for log4j.rootLogger property
       
    4. Check [Install Dir]/server/logs/rs.log file for any obvious errors (for example out of disk space)
       
    5. Gather log files according to Report Builder log files document.

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Document Information

Modified date:
25 July 2019

UID

swg21986643