IBM Support

No buffer space available error in IBM Content Collector logs

Troubleshooting


Problem

IBM Content Collector (ICC) task route stops processing or comes to a halt after running for a few days. Problem continues even after restarting the services.

Symptom

"No buffer space available" error can be seen in multiple places in the IBM Content Collector logs.

For example, it could be in the CM8 connector log:

    2016-05-24T10:02:28Z Error Failed to process task. Reason: Error Code = 0, Error State = "", Error Id = 403, Exception Id = 6, Name = "DKDatastoreAccessError" : com.ibm.mm.sdk.common.DKDatastoreAccessError: No buffer space available (maximum connections reached?)

It could also be in the email connector log:
    2016-05-20T14:13:41.133Z SEVERE [0] AFUP0010E A thread connection to the mail server could not be established. See the following message: com.ibm.afu.mailinterface.MailException: javax.naming.CommunicationException: host:domain.com:3268 [Root exception is java.net.SocketException: No buffer space available (maximum connections reached?): connect] [com.ibm.afu.mailconnector.AbstractConnectorService initMailinterface] [pool-2-thread-1 0]Exception [com.ibm.afu.mailinterface.MailException]: javax.naming.CommunicationException: host.domain.com:3268 [Root exception is java.net.SocketException: No buffer space available (maximum connections reached?): connect]
    .....
    Caused by:
    Exception [javax.naming.CommunicationException]: host.domain.com:3268
    .....
    Caused by:
    Exception [java.net.SocketException]: No buffer space available (maximum connections reached?):
    .....

Cause

Some ICC components create loopback sockets on the computer.

Environment

IBM Content Collector
Windows 2008 R2 server

Diagnosing The Problem

When "no buffer space available" error is being reported, system memory may not be at its maximum. There is no sign that the system is running out of memory.

Verifying that this hotfix is installed on the ICC server:
https://support.microsoft.com/en-us/kb/2577795

Resolving The Problem

If the hotfix is not already applied, apply the hotfix:
https://support.microsoft.com/en-us/kb/2577795

[{"Product":{"code":"SSAE9L","label":"Content Collector"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"All Content Collector products","Platform":[{"code":"PF033","label":"Windows"}],"Version":"3.0;4.0;4.0.1;4.0.1.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21984808