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Why am I getting a DIA8411C A file "" could not be found in the db2diag.log?

Question & Answer


Question

Why am I getting a DIA8411C A file "" could not be found in the db2diag.log?

Cause

 

2016-02-03-11.02.46.653000-200 I225897131F0639 LEVEL: Info
PID : 3294 TID : 2116 PROC : db2syscs.exe
INSTANCE: DB2 NODE : 000 DB : SAMPLE
HOSTNAME: myhost1
EDUID : 1963 EDUNAME: db2loggr (SAMPLE) 0
FUNCTION: DB2 UDB, data protection services, sqlpgOpenLogExtent, probe:2164
MESSAGE : ZRC=0x860F000A=-2045837302=SQLO_FNEX "File not found."
DIA8411C A file "" could not be found.
DATA #1 : String, 19 bytes
Log is not found...
DATA #2 : Codepath, 8 bytes
19:24:26
DATA #3 : String, 99 bytes
extNum / logLocation / logStreamId / callerFlag / logFileName1 / logFileName2 / callerSpecifiedPath
DATA #4 : SQLPG_EXTENT_NUM, PD_TYPE_SQLPG_EXTENT_NUM, 4 bytes 47958
DATA #5 : unsigned integer, 4 bytes 0
DATA #6 : db2LogStreamIDType, PD_TYPE_DB2_LOG_STREAM_ID, 2 bytes 0
 

Answer


These messages are related to the log file clean-up during runtime.

The 'File not found' message relates to a file that has already been
renamed or deleted. These are informational message are should not be
of concern unless followed by other Error messages.

So one thing to try is deactivate the db, rename the db2dia.log using
db2diag -A, then activate the db again and monitor. A new log chain
will be created and the above errors should go away.

[{"Product":{"code":"SSEPGG","label":"Db2 for Linux, UNIX and Windows"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"DB2 Tools - db2diag.log","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"9.7;10.1;10.5;11.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
07 December 2022

UID

swg21982537