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Data Protection for SAP HANA® setup.sh receives a connection failure error

Troubleshooting


Problem

IBM Spectrum Protect for Enterprise Resource Planning: Data Protection for SAP HANA® setup.sh connection failure in alter configuration step.

Symptom

* -10709: Connection failed (RTE:[89006] System call 'connect' failed, rc=111:Connection refused)
Processing of hdbsql command failed!

Cause

The localhost is not properly mapped to 127.0.0.1.

Diagnosing The Problem

There is an existing APAR, IT11526 that addresses a similar problem when the setup.sh script is run on the SAP HANA® stand-by node. However, this connection failure happens on the active/worker node. After enabling the debug for setup.sh, by editing setup.sh and changing the line for setopts from +x to -x,

    setopts="-x"

the setup.sh output displays the hdbsql command reporting the connection failure as follows:
    ++ su - ogpadm -c 'hdbsql -i 00 -u SYSTEM -p \p\a\s\s\w\o\r\d -j "ALTER SYSTEM ALTER CONFIGURATION ('\''global.ini'\'', '\''SYSTEM'\'') SET ('\''backint'\'', '\''data_backup_parameter_file'\'') = '\''/usr/sap/TEST/SYS/global/hdb/opt/hdbconfig/initTEST.utl'\''"'
    * -10709: Connection failed (RTE:[89006] System call 'connect' failed, rc=111:Connection refused)
    + hdbsqlOutput=
    + checkSuccessHdbsql 43
    + set -x
    + '[' 43 -ne 0 ']'
    + echo 'Processing of hdbsql command failed!'
    Processing of hdbsql command failed!

The command does not include -n <server>[:<port>] parameter, which is the name of the host on which the database instance is installed (the default is: localhost). hdbsql connects to the localhost when invoked without the option '-n'. This command also fails when it is run manually.
By adding the -n parameter to hostname, the command is successful as follows:
    saphana:~ # su - ogpadm -c 'hdbsql -n saphana -i 00 -u SYSTEM -p \p\a\s\s\w\o\r\d -j "ALTER SYSTEM ALTER CONFIGURATION ('\''global.ini'\'', '\''SYSTEM'\'') SET ('\''backint'\'', '\''data_backup_parameter_file'\'') = '\''/usr/sap/TEST/SYS/g lobal/hdb/opt/hdbconfig/initTEST.utl'\''"'
    0 rows affected (overall time 200.000 msec; server time 200.000 msec)

Resolving The Problem

Add loopback host mapping to /etc/hosts.

Related Information

[{"Product":{"code":"SSZHVN","label":"Tivoli Storage Manager for Enterprise Resource Planning"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Data Protection for SAP HANA\u00ae","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Product Synonym

TSM Tivoli Storage Manager

Document Information

Modified date:
17 June 2018

UID

swg21982375