IBM Support

"An error occurred ... The underlying connection was closed: An unexpected error occurred on a send" when launching Controller client, caused by IIS SSL connection protocols being disabled

Troubleshooting


Problem

User launches Controller client. User receives an error.

Symptom

Example #1 (Controller 10.2.1):

An error occurred while trying to access the server

Error Details:
The underlying connection was closed: An unexpected error occurred on a send

Cause

There are several known causes for this error.

  • See separate IBM Technote #0741571 for more examples.

 

This Technote specifically relates to the scenario where the Controller application server's website (IIS) required connection protocol(s) have been disabled.
 
Example #1:
In one real-life example, the third-party (IBM) tool 'IIS Crypto' had been used to lock down the webserver so that only a very few protocols were enabled:
image-20181121075315-1

  

Most importantly, TLS 1.0 and 1.1 had been disabled (forcing the application server to only accept TLS 1.2 connections).

Resolving The Problem

Fix (Modern versions of Controller)

Reconfigure the client device so that it forces .NET applications to use TLS 1.2.

  • TIP: For instructions, see separate IBM Technote #883036.

 

Workaround (Old/unsupported versions of Controller)

Re-enable the relevant/required IIS communication protocols.

[{"Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"ARM Category":[{"code":"a8m0z000000Gmx2AAC","label":"Error"}],"ARM Case Number":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Version(s)"}]

Document Information

Modified date:
16 September 2020

UID

swg21981522