Troubleshooting
Problem
Attempts to add items in Add Products screen shows item availability as Out of stock in IBM Call Center for Commerce (CCC).
Symptom
Steps to reproduce:
- Create an item and adjust its onhand inventory.
- Configure and run the RTAM agent.
- In CCC, click on Create Order link.
- Go to Add Products screen, input the item id & click Add button.
- In the Delivery method panel Out of Stock appears.
- Now click Save button.
Availability gets changed from Out of Stock to Today.
Cause
Basic Configuration is not updated with the correct Distribution Group (DG).
Diagnosing The Problem
CCC reads the inventory availability from YFS_INVENTORY_ALERTS. When Default DG is not selected in Basic configuration; no SQL is run on YFS_INVENTORY_ALERTS as the DISTRIBUTION_RULE_ID has null value.
However, when Default DG is selected in Basic configuration; following SQL runs on YFS_INVENTORY_ALERTS containing the appropriate value for DISTRIBUTION_RULE_ID.
For example:
SELECT /*YANTRA*/ YFS_INVENTORY_ALERTS.* FROM YFS_INVENTORY_ALERTS YFS_INVENTORY_ALERTS WHERE ( INVENTORY_ITEM_KEY IN ( '2015100711341526806' ) ) AND ( ORGANIZATION_CODE IN ( 'DEFAULT' ) ) AND DISTRIBUTION_RULE_ID = '16931_DG'
Resolving The Problem
Ensure that the DG (containing the node having the availability of the item) is selected, against Default Distribution Rule to be used when no sourcing rule found.
Was this topic helpful?
Document Information
Modified date:
16 June 2018
UID
swg21972387