IBM Support

Date appears on LMS in MM/DD/YYYY format when it is set to be DD/MM/YYYY

Troubleshooting


Problem

Date appears on LMS in MM/DD/YYYY format when it is set to be DD/MM/YYYY

Symptom

Date appears on LMS in MM/DD/YYYY format when it is set to be DD/MM/YYYY under LMS Administration>System Administrator role>System>System Appearance>Language Sets.

Cause

The date format, MM/DD/YYYY or DD/MM/YYYY, depends on the language set configuration.

The configuration chosen in the LMS (system Administrator role) by going to System menu , editing the Appearance section and modifying the Language Sets, ONLY affects the LMS Administration date format but not the Participate side of it.

Resolving The Problem


The configuration for Participate side is done under member profile >Language Set field. If Language set is selected "English" on member profile, the member will see US date format i.e. MM/DD/YYYY.



In order to have European date format, i.e. DD/MM/YYYY, the language set on member profile should be selected as English (United Kingdom).

In case "English (United Kingdom)" option is not showing under language set selection on member profile, This needs to be first enabled by checking the Literals check box for "English (United Kingdom)" under Admin console>System > Literals >Languages.

If a non-English language set is being used the date format will be according to that language set.


[{"Product":{"code":"SSDN58","label":"IBM Kenexa LMS"},"Business Unit":{"code":"BU055","label":"Cognitive Applications"},"Component":"Not Applicable","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"Version Independent","Edition":"All Editions","Line of Business":{"code":"","label":""}},{"Product":{"code":"SSDN58","label":"IBM Kenexa LMS"},"Business Unit":{"code":"BU055","label":"Cognitive Applications"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"","label":""}},{"Product":{"code":"SSQV8F","label":"IBM Kenexa LMS on Cloud"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB27","label":"Talent Management Solutions"}},{"Product":{"code":"SSDMNJ","label":"IBM Kenexa Participate"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB27","label":"Talent Management Solutions"}},{"Product":{"code":"SSDMMH","label":"IBM Kenexa Participate on Cloud"},"Business Unit":{"code":"BU055","label":"Cognitive Applications"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB27","label":"Talent Management Solutions"}}]

Product Synonym

LMS;Participate;Date Format

Document Information

Modified date:
17 June 2018

UID

swg21970569