IBM Support

用户权限问题导致数据库恢复失败于SQL5193N错误

Troubleshooting


Problem

Tivoli Storage Manager服务器数据库恢复失败,错误信息显示用户没有权限访问数据库。

Symptom

RESTORE DB命令失败于错误:

ANR9999D_3831306406 ReportSQLDiagInfo(dbieval.c:1572) Thread<11>: Missing
sqlState=42524, sqlCode=-5193 from table. Returning rc = 9994.
ANR0162W Supplemental database diagnostic information: -1:42524:-5193
([IBM][CLI Driver][DB2/NT64] SQL5193N The current session user does not have
usage privilege on any enabled workloads. SQLSTATE=42524
).
ANR4635I Point-in-time database restore complete, restore date xxxx.
Entering exception handler.

Cause

执行恢复操作的用户ID没有访问数据库的权限。

Resolving The Problem

使用DB2实例所属用户ID执行恢复数据库的操作。如果在另外的系统而非原系统执行数据库恢复,请先创建和原系统一样的用户ID,然后用此用户登录执行恢复操作。如果因为某种原因导致原系统的DB2实例所属用户ID未知(例如原系统崩溃且数据丢失,新的管理员不是原系统的创建者且没有权限访问原系统,等等),请执行下列步骤来对新的用户ID授权:

1. 删除当前的数据库:
dsmserv removedb tsmdb1

如果dsmserv命令有问题,也可以使用DB2命令来删除数据库:
db2 drop db tsmdb1

2. 设置DB2权限:
db2stop
db2set DB2_RESTORE_GRANT_ADMIN_AUTHORITIES=ON
db2start

设置完毕后,用户执行数据库恢复的用户将会包含以下权限:
SECADM
DBADM
DATAACCESS
ACCESSCTRL

3. 执行RESTORE DB,用户权限错误将被解决。

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"6.3;7.1","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21970515