IBM Support

Recover from a failed ICC installation or upgrade

Troubleshooting


Problem

After ICC installation or upgrade failed, ICC task route service cannot be started successfully. Subsequent installation also failed even after running uninstall.

Symptom

In the installation log (e.g. ContentCollector\Uninstall\logs\IBM_Content_Collector_4_0_1_0_InstallLog.txt), you see the following error message:


    ICC install helpers:      File: TaskRoutingServiceSetup.msi,
    EXITCODE:1603
                             Status: FATAL ERROR
                             Additional Notes: FATAL ERROR -
    -- stdout -- stdout -- stdout -- stdout ---------->
    There may be more details in file 'C:\Program Files
    (x86)\IBM\ContentCollector\msi\TaskRoutingServiceSetup.msi.log'

    ICC install helpers:      File: FileSystemConnectorUISetup.msi,
    EXITCODE:1603
                             Status: FATAL ERROR
                             Additional Notes: FATAL ERROR -
    -- stdout -- stdout -- stdout -- stdout ---------->
    There may be more details in file 'C:\Program Files
    (x86)\IBM\ContentCollector\msi\FileSystemConnectorUISetup.msi.log'

    ICC install helpers:      File: TxtExtractUISetup.msi, EXITCODE:1603
                             Status: FATAL ERROR
                             Additional Notes: FATAL ERROR -
    -- stdout -- stdout -- stdout -- stdout ---------->
    There may be more details in file 'C:\Program Files
    (x86)\IBM\ContentCollector\msi\TxtExtractUISetup.msi.log'


Cause

ICC service is not removed completely during uninstall and it causes errors in the subsequent installation.

Resolving The Problem

Perform the following steps to resolve the problem:

  • Run ICC uninstaller.
  • Verify all ICC services are removed.
    If any service that starts with name "IBM Content Content" still exists, manually remove that service. For example, if the task route service still exists, run this command in a command window to remove it:

    • sc delete ibm.ctms.taskrouteservice
  • Ensure the following registry is deleted:

    • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\IBM\Content Collector
      HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\IBM\EMRC

  • Delete the ContentCollector folder manually.
  • Reboot the server.

[{"Product":{"code":"SSAE9L","label":"Content Collector"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Content Collector for Email","Platform":[{"code":"PF033","label":"Windows"}],"Version":"3.0;4.0;4.0.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21970065