IBM Support

MAPI_E_NETWORK_ERROR when IBM Content Collector connects to Microsoft Exchange server.

Troubleshooting


Problem

IBM Content Collector (ICC) fails to connect to Microsoft Exchange server with MAPI_E_NETWORK_ERROR,

Symptom

In the ICC email connector log, MAPI_E_NETWORK_ERROR is reported.

Cause

Unable to connect to the Exchange server using the ICC default profile.

Environment

IBM Content Collector for Email
Microsoft Exchange as source system.

Diagnosing The Problem

MAPI_E_NETWORK_ERROR may be caused by various reasons.

  • In the Outlook Client on the ICC server, open the mailbox for the user account that is starting the ICC email connector service.
  • If the user mailbox cannot be opened in Outlook Client, you should contact your Exchange administrator to troubleshoot the issue further. Otherwise, try the steps outlined in the next section.

Resolving The Problem

ICC automatically creates an Outlook profile before it connects to the Exchange server. Sometimes, the issue can be resolved by manually creating such profile. If the email connector finds there is an existing profile, it will use that profile and will not create a new one.

Profile Name


    First, you need to identify the profile name that ICC is using. By default, the ICC profile name uses the following convention:

      AFU_<ExchangeServerHostName>

    To verify the Exchange server host name, go to ICC Configuration Manager > Connectors > Email > Connection tab.
    • If you are using Manual configuration, the host name configured here will be used in the profile name.
    • If you are using Automatic configuration, then you may need to enable email connector Trace level log to look for the information.
      1. In ICC Configuration Manager, Connectors > Email > General tab. Set Log level to "Trace".
      2. Restart ICC task route service to take effect.
      3. In the email connector log (e.g. afu_mailconnector_trace_(MAPI)0.log), search for "profile name".
        For example, the following line shows that the profile name used by ICC is AFU_exchange.ibm.com:
      1.
        2016-03-31T22:08:08.478Z FINEST [161] [C-TRC] created CsxMAPIProfile instance with profile name : 'AFU_EXCHANGE.IBM.COM' [CsxMAPIProfile.cpp:107] [JniInterface logTrace] [pool-2-thread-1 1]

Creating the Profile

    Once you identified the profile name used by ICC, you can manually create such profile.
    1. Log on to Windows on the ICC server using the same user account that you start the ICC Email Connector service.
    2. Go to Control Panel > Mail (32-bit) > Show Profiles.
    3. Click Add.... and enter the profile name using the above convention.
    4. Select Manual setup or additional server types. Click Next.
    5. Select Microsoft Exchange Server or compatible service. Click Next.
    6. Enter the Exchange server name in Server and the username in User Name. Click Check.
      If the user is found, the value of the User Name will have an underline. The value may also be changed automatically to another format recognized by the system.
    7. Do not select Use Cached Exchange Mode.
    8. Click Next.
    9. Click Finish and save any changes.

    Restart ICC task route service and the email connector will use the existing profile to connect to Exchange.

    If the issue cannot be resolved by the above steps, contact IBM support for further assistance.


[{"Product":{"code":"SSAE9L","label":"Content Collector"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Content Collector for Email","Platform":[{"code":"PF033","label":"Windows"}],"Version":"3.0;4.0;4.0.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21967889