Question & Answer
Question
How can I find the patch level of my current DASH install?
Cause
Some versions of DASH have additional cumulative patches that require previous patches be installed. Any installed patches don't show up in the output of the "consolecli Version" command.
Answer
The patch level for a DASH release is recorded in this file: /profile/installedApps/JazzSMNode01Cell/isc.ear/isclite.war/WEB-INF/config/isc.version.properties
The isc.patch.level value will get updated with the patch level if it applies. Here is an example of the contents of this file:
isc.name=IBM Dashboard Application Services Hub
isc.version=3.1.1.0
isc.release.name=IBM Dashboard Application Services Hub 3.1.2.0
isc.build.level=201505020120
isc.build.date=05/02/15
*isc.patch.level=
*isc.patch.level will get updated with the patch level, if this line doesn't exist or doesn't have a value, it's because there are no patches applied for the current DASH version.
To get the DASH cumulative Patch level, you can check to see if the Patches directory exists in <JazzSM_HOME>/ui directory. If so, you can see what DASH Cumulative patches have been installed. This link will show you the Cumulative patch, and the associated number you may see in the Patches directory:
www.ibm.com/developerworks/community/wikis/home?lang=en#!/wiki/W8b1151be2b42_4819_998e_f7de7db7bfa2/page/Download%20Cumulative%20Patches%20-%20UI%20Services%20%28DASH%29
The next way is to execute this command: <JazzSM_HOME>/ui/bin/consolecli.[sh || bat] Version.
[{"Product":{"code":"SSRLR8","label":"Tivoli Components"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Jazz for Service Management","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"","label":""}}]
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Document Information
Modified date:
17 June 2018
UID
swg21967886